Starmade | lock missiles target incorrectly when fired at a non system target
Closed, FinishedPublic

Description

When using lock on missiles I've noticed they have a chance to completely ignore the target they are locked on to instead choosing to target empty space.

Video

Details

Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.201.095
Category
Control Block System: Weapons
First occurrence (version)
199.535
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
AMD/ATI
Steps to reproduce
  1. Make a lockable missile, preferable with multiple outputs as that makes it easier to see the result
  2. Make a 2 targets:
    1. target that has only/mostly systems (thrusters, power)
    2. target that only has hull (make a station, as the ship core also counts as a system it seems)
  3. Lockon to each target and fire

the target with systems gets targeted properly
the one with only hull, doesn't and the missile should completely miss and head for some invisible target nearby.

You can also do a mix of systems and hull when using a missile launcher with multiple outputs. You'll see most missiles head for systems, and the ones that don't just miss completely.

Tester information (Internal use only)

Missiles lock on fine when used against a target that has systems.
If it doesn't have systems, the missiles will target its Center of Mass which seems to be completely misaligned of the actual Center of Mass. It's not really going for a neighbouring sector, but the CoM used for targeting definitely moves when editing your target although not in the way it should.

Serverconfig (server.cfg)
 <replace this block with the file content, 
but do not remove the first and last line. 
Before using the paste function, mark the area from the 
opening angle bracket to the closing angle bracket>
Clientconfig (settings.cfg)
 <replace this block with the file content, 
but do not remove the first and last line. 
Before using the paste function, mark the area from the 
opening angle bracket to the closing angle bracket>
lancake claimed this task.EditedMay 15 2017, 12:11 PM
lancake moved this task from New / Unconfirmed to Feedback on the Issue Navigation board.
lancake added a subscriber: lancake.

-Feedback-

Not sure why width would matter here, at least it doesn't in my examples. Your 2 meter wide ship has the missile computer in front of the ship core, they're not offset from your aiming reticule so that would be why they always hit the ship core if you're aiming directly at it, tracking or no tracking.

I cannot see any change in behavior no matter what my ship's dimensions are.
My first lockable missile hits just fine, the ones after that at the same target are not and they aim for something completely different.
That however doesn't describe what you mention, could you check that small scale example out again and see if it corresponds to what I experience?

Your video, although clearly showing the issue is hard to use as comparison. There might also be cross-sector issues involved from the sector markers I could see which could explain why most are targeting something in a neighboring sector

lancake shifted this object from the S1 Public space to the S3 Starmade space.May 15 2017, 12:15 PM
lancake changed the task status from "Open" to "Feedback".
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
Restricted Application added a project: Waiting on Author. · View Herald TranscriptMay 15 2017, 12:15 PM

My homing missles do all diverge from the locked target.
In single- and multiplayer. They diverge from the target in perfect curve away from it into empty space.

Restricted Application edited projects, added Customer responded; removed Waiting on Author. · View Herald TranscriptMay 19 2017, 4:48 PM
Restricted Application changed the task status from "Feedback" to "Open". · View Herald Transcript

I have had this issue when using select target lockon missile turrets

lancake changed the task status from "Open" to "Feedback".May 23 2017, 12:06 PM

As I'm experiencing it too, then it can happen to other people as well. I do not need confirmation on that, just the questions I asked in my feedback suggestion.
Does width matter here and if off-center weapons cause this behavior to always trigger? From what I've seen it's no, but only the task owner can double check this for sure which is why the issue is set on feedback for confirmation.

Restricted Application edited projects, added Waiting on Author; removed Customer responded. · View Herald TranscriptMay 23 2017, 12:06 PM

On more testing it looks more like editing a ship is what changes the tracking. The first time I put a missile computer down the missile seems to track but if I delete it and re-place it it won't track properly so width doesn't seem to be a factor.

Restricted Application edited projects, added Customer responded; removed Waiting on Author. · View Herald TranscriptMay 25 2017, 9:24 PM
Restricted Application changed the task status from "Feedback" to "Open". · View Herald Transcript

I can say Ive experienced this


this is missiles from multiple turrets after engaging an "inert" target brick of armour with Pirate AI active. Turrets are any mode firing. white streaks are just dumbfire spammers

However, this behaviour almost dispersal the moment there is a "proper" ship being used as the target. It could be related to missiles targeting specific systems.

Aceface added a subscriber: Aceface.Jun 1 2017, 1:41 PM

happens almost every time i use missiles on multiplayer servers

lancake moved this task from Feedback to Confirmed on the Issue Navigation board.Jun 8 2017, 10:27 AM
lancake changed the task status from "Open" to "In Queue".Jul 15 2017, 1:52 PM

-confirmed-

Missiles lock on fine when used against a target that has systems.
If it doesn't have systems, the missiles will target its Center of Mass which seems to be completely misaligned of the actual Center of Mass. It's not really going for a neighbouring sector, but the CoM used for targeting definitely moves when editing your target although not in the way it should.

lancake changed the title from "Target Lock Missiles Track Empty Space" to "lock missiles target incorrectly when fired at a non system target".Jul 15 2017, 1:57 PM
lancake raised the priority of this task from "Normal" to "High".
lancake edited Steps to reproduce. (Show Details)
lancake edited Tester information (Internal use only). (Show Details)
lancake changed Affected Gamemode(s) from none/unspecified to Single and Multi.
lancake changed Last tested (version) from 199.535 to 199.646.
lancake edited Steps to reproduce. (Show Details)
AndyP moved this task from Backlog / Unclassed to Beta on the CBS: Weapons board.Jul 20 2017, 11:04 PM

This might be related to an issue on of our moderators reported.

Arbiter has created a summons report with the message: missles seem to glitch out 100 of the time when targeting a power 1.0 ship fired from a power 2,0 ship. even when fireing very small numbers of missles, the first salvo fires off into space, then everything that fires just freezes

lancake changed the task status from "In Queue" to "Resolved".Jun 29 2018, 11:57 AM

should have been fixed, other issues remain though.

Restricted Application added a project: Quality Assurance. · View Herald TranscriptJun 29 2018, 11:57 AM
Restricted Application added a subscriber: AndyP. · View Herald Transcript
lancake closed this task as "Closed".

-QA Testing-

Fix confirmed.

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptJun 29 2018, 3:43 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake changed Last tested (version) from 199.646 to 0.201.095.Jun 29 2018, 3:44 PM