Starmade | transparency issue with blocks next to slabs
Confirmed task for development, NormalPublic

Description

The partial faces of slabs next to transparent slabs, that are equally high or higher, are not rendered.


If the orientation of the slabs is not the same, the face is rendered, which is intended.

Details

Commits
Restricted Diffusion Commit
Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19541
Category
Engine
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce

Place a non-transparent slab
Place a transparent slab, that is higher, next to it, both facing the same way. Their partial faces should touch.
Observe.

SmilingDemon shifted this object from the S1 Public space to the S3 Starmade space.
SmilingDemon changed the visibility from "Custom Policy" to "Public (No Login Required)".
SmilingDemon changed the edit policy from "Task Author" to "Starmade (Project)".
SmilingDemon changed Category from none/unspecified to Engine.
SmilingDemon changed Affected Gamemode(s) from none/unspecified to Single and Multi.
SmilingDemon edited Serverconfig (server.cfg). (Show Details)
SmilingDemon edited Clientconfig (settings.cfg). (Show Details)
SmilingDemon added a subscriber: jzimmerman4.
Restricted Application added a project: Issue Navigation. · View Herald TranscriptNov 20 2015, 11:55 AM
SmilingDemon added a subscriber: SmilingDemon.

Split from T874 as own report

Megacrafter127 set Task Type to Bug.
Megacrafter127 set Reproducible to Yes.
Megacrafter127 set Last tested (version) to 0.19492.
Megacrafter127 set OS-Specific to No.
Megacrafter127 set Hardware-Specific to No.
Megacrafter127 set Video Card Vendor to uncertain.
Megacrafter127 edited Serverconfig (server.cfg). (Show Details)
Megacrafter127 edited Clientconfig (settings.cfg). (Show Details)
Megacrafter127 changed the task status from "Open" to "In Queue (Game)".

-Confirmed-
Only affects not-glitched full faces of non-full blocks, with the exception of other slabs.

Restricted Application edited projects, added Game Development, Starmade; removed Issue Navigation. · View Herald TranscriptNov 20 2015, 12:13 PM

The blueprint of the assembly used to test this:
visibilityTest.sment1 KB

schema changed the task status from "In Queue (Game)" to "Resolved" by committing Restricted Diffusion Commit.Nov 21 2015, 8:20 AM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptNov 21 2015, 8:20 AM
Megacrafter127 closed this task as "Closed".Nov 21 2015, 8:39 AM

-QA Testing-
Fix confirmed.
No face of a block is transparent in any of the cases described in the description.

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptNov 21 2015, 8:39 AM
lancake reopened this task as "Open".EditedNov 23 2015, 2:55 PM
lancake added a subscriber: lancake.

Not fixed, needs retesting for transparent slabs and blocks.


Restricted Application added a project: Issue Navigation. · View Herald TranscriptNov 23 2015, 2:55 PM
Megacrafter127 changed the task status from "Open" to "In Queue (Game)".Nov 24 2015, 5:42 AM

-Confirmed-
The partial faces of slabs next to transparent slabs, that are equally high or higher, are not rendered.


If the orientation of the slabs is not the same, the face is rendered, which is intended.

Restricted Application edited projects, added Game Development; removed Issue Navigation. · View Herald TranscriptNov 24 2015, 5:42 AM
schema changed the task status from "In Queue (Game)" to "Resolved".Dec 3 2015, 5:54 PM
schema added a subscriber: schema.

from dev version 0.19511+

Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptDec 3 2015, 5:54 PM
Megacrafter127 changed the task status from "Resolved" to "In Queue (Game)".Dec 5 2015, 1:56 PM

-QA Testing-
Not fixed, still occurring in v0.19519. Behaviour did not change.

Restricted Application edited projects, added Game Development; removed Quality Assurance. · View Herald TranscriptDec 5 2015, 1:56 PM
Megacrafter127 changed Last tested (version) from 0.19492 to 0.19519.Dec 5 2015, 1:56 PM
Megacrafter127 edited the task description. (Show Details)
Megacrafter127 changed Last tested (version) from 0.19519 to 0.19541.Jan 9 2016, 2:12 PM
Megacrafter127 edited Steps to reproduce. (Show Details)

Reconfirmed for 0.19541
Filled out steps to reproduce.

lancake changed the title from "Transperancy issue with blocks next to slabs" to "transparency issue with blocks next to slabs".Apr 17 2016, 10:11 AM
lancake mentioned this in Unknown Object (Maniphest Task).Apr 17 2016, 10:01 PM
AndyP changed the task status from "In Queue (Game)" to "In Queue".Mar 10 2017, 5:12 PM
Restricted Application added a project: Engine. · View Herald TranscriptMar 10 2017, 5:12 PM
AndyP moved this task from Backlog / Unclassed to Rendering on the Engine board.Mar 16 2017, 2:41 PM
AndyP edited projects, added Engine (Rendering); removed Engine.