Starmade | Templates rotation (and mirror cubes) does not appear to include docking or rails
Closed, FinishedPublic

Description

When placing a template (specifically the USD from Bench in the Logic area). The template loads and initially displays properly (rail & docking facing correctly) but upon rotation these specific blocks appear to maintain their original facing and do not update as the template is rotated.

All rotational direction produce the same result. Should be easy to reproduce.


"All rotational direction produce the same result"

definitely not the case ... they are wrong .. but not the same in every orientation


(market a few of the wrong ones with arrows)
i am not even sure if a few of them can be rotated normally


a few more samples

Details

Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19522 (Dev)
Category
Engine
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
NVIDIA
User/Reporter/Contact
Username on Registry
Achriel
Username/Profile on Steam
Achriel
Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
Achriel created this task.Dec 5 2015, 8:06 PM
Achriel changed Category from none/unspecified to Control Block System: Rails/Docking.
Achriel changed Affected Gamemode(s) from none/unspecified to Single and Multi.
Achriel changed Reproducible from uncertain to Yes.
Achriel set Last tested (version) to 0.19519.
Achriel changed Video Card Vendor from uncertain to NVIDIA.
Achriel edited Serverconfig (server.cfg). (Show Details)
Achriel edited Clientconfig (settings.cfg). (Show Details)
Achriel set Username on Registry to Achriel.
Achriel set Username/Profile on Steam to Achriel.
Achriel added a subscriber: Achriel.
Restricted Application added a project: Issue Navigation. · View Herald TranscriptDec 5 2015, 8:06 PM
SmilingDemon triaged this task as "High" priority.Dec 9 2015, 6:37 PM
SmilingDemon shifted this object from the S1 Public space to the S3 Starmade space.
SmilingDemon changed the visibility from "Custom Policy" to "Public (No Login Required)".
SmilingDemon changed the edit policy from "Task Author" to "Starmade (Project)".
SmilingDemon set Task Type to Bug.
SmilingDemon changed Category from Control Block System: Rails/Docking to Engine.
SmilingDemon changed Last tested (version) from 0.19519 to 0.19522 (Dev).
SmilingDemon set OS-Specific to No.
SmilingDemon set Hardware-Specific to No.
Restricted Application added a subscriber: AndyP. · View Herald TranscriptDec 9 2015, 6:37 PM

-Validated-

not exactly

fast test shows that a loaded template and rotating it changes block orientation ...
but not in the expected way

what was the template you used when you did see the not effect ?

The 'NOT' was a correct as my 1st message had a typo (did instead of did NOT)
I was using benches UDP template when I noticed the oddity then made a few more template and it appears to be a consistently occurring error.

i thought you would simply add the template or provide the link

i will search then for it in the evening.

"All rotational direction produce the same result"

definitely not the case ... they are wrong .. but not the same in every orientation


(market a few of the wrong ones with arrows)
i am not even sure if a few of them can be rotated normally

is that what you have seen too ?

no further answers
putting in queue with a few more explaining pictures

SmilingDemon closed this task as "Unknown Status".
Restricted Application edited projects, added Starmade, Game Development; removed Issue Navigation. · View Herald TranscriptDec 31 2015, 9:33 PM

The Problem seems to be, that the rotation of rails is inversed, when using mouse wheel or Ctrl+mouse wheel.
Shift+mouse wheel is working fine.

I can provide a picture for better demonstration, if you need it.

AndyP added a comment.EditedMar 5 2016, 11:01 PM

Also affects symmetry mode with "mirror cubes".

To clarify:

Building in symmetry and mirror cubes enabled, also results in some orientations being off, so I assume it may be related to the different scroll order?

AndyP changed the title from "Templates rotation does not appear to include docking or rails" to "Templates rotation (and mirror cubes) does not appear to include docking or rails".Mar 5 2016, 11:02 PM
AndyP mentioned this in T697: Rail facing problem.
lancake mentioned this in Unknown Object (Maniphest Task).Apr 26 2016, 10:13 AM
schema reopened this task as "Resolved".Jan 27 2017, 2:05 PM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptJan 27 2017, 2:05 PM
SmilingDemon closed this task as "Closed".Jan 27 2017, 8:48 PM

-QA Testing-
looks good to me now

havnt seen a wrong rotation when copy pasting or placing in symetrie

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptJan 27 2017, 8:48 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
Restricted Application added a project: Engine. · View Herald TranscriptFri, Mar 10, 6:20 PM