Starmade | empty labels when "German" language choosen
Closed, FinishedPublic

Description

The most labels are empty when you choose german as language.
I'm not sure if other "not english" languages also effected.

possible resolution: use english snipped as fallback when current language snipped is missing

Details

Commits
Restricted Diffusion Commit
Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.200.253
Category
Ingame GUI/HUD
First occurrence (version)
0.200.251
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce

Choose german language.

Related Objects

HKMSC created this task.Dec 12 2017, 9:42 AM
HKMSC changed the title from "empty labels when not "English" language choosen" to "empty labels when "German" language choosen".Dec 12 2017, 9:50 AM
HKMSC edited the task description. (Show Details)
HKMSC edited the task description. (Show Details)
AndyP claimed this task.Dec 12 2017, 10:04 PM
AndyP shifted this object from the S1 Public space to the S3 Starmade space.
AndyP changed the visibility from "Custom Policy" to "Public (No Login Required)".
AndyP changed the edit policy from "Task Author" to "Starmade (Project)".
AndyP changed Affected Gamemode(s) from none/unspecified to Single and Multi.
AndyP changed Last tested (version) from 0.200.251 to 0.200.253.
AndyP changed Category from Typos/Content to Ingame GUI/HUD.
AndyP moved this task from Unclassed to Issue affecting current dev-build on the Starmade board.
AndyP changed the task status from "Open" to "In Queue".

-Confirmed-

Most noticeable spots:

  • Language selection screen
  • Ingame "Top button bar - "fleets, faction, inventory, catalogue" completely messed up the order of the button labels.
Restricted Application edited projects, added Game Development, GUI/HUD; removed Issue Navigation. · View Herald TranscriptDec 12 2017, 10:07 PM
AndyP raised the priority of this task from "Normal" to "Pre-Release Quality Assurance".Dec 12 2017, 10:07 PM
AndyP added a project: RC-Report.
schema added a subscriber: schema.Dec 18 2017, 9:01 PM

I fixed the issue with the empty boxes (was not a language but a cleanup problem with the new font system, which got triggered on language switch (after restart the problem was gone))

Wrong order is a different issue. i'd need to reset the ids of those strings so i would need to know all other affected areas besides the top button bar.

schema changed the task status from "In Queue" to "Resolved" by committing Restricted Diffusion Commit.Dec 18 2017, 9:01 PM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptDec 18 2017, 9:01 PM
lancake lowered the priority of this task from "Pre-Release Quality Assurance" to "High".Jan 20 2018, 8:03 PM
AndyP moved this task from Backlog / Unclassed to Alpha on the GUI/HUD board.Jan 22 2019, 9:26 AM
AndyP closed this task as "Closed".Jan 22 2019, 4:29 PM
AndyP moved this task from Backlog / Unclassed to Confirmed fix on the Quality Assurance board.

Fix confirmed

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptJan 22 2019, 4:29 PM