Starmade | Armor HP Bonus deals bonus Structure HP Damage.
Closed, FinishedPublic

Description

What it says in the title.

Any effect that lists bonus Armor HP damage deals that bonus to Structure HP as well.

Vidya evidence:
https://youtu.be/Y4BebjM9l0Y

Against a 100 SHP Reactor block:

10 Cannon - 100 SHP damage
5 Cannon 5 Punch - 125 SHP damage
5 Cannon 5 Pierce - 150 SHP damage

ToddoftheYear on SMD Chat confirmed that Beams and Missiles also experience this odd behavior.

Details

Commits
Restricted Diffusion Commit
Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.199.435
Category
Control Block System: Weapons
First occurrence (version)
0.199.353
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce

1: Make weapon.
2: Shoot block with SHP.

Tester information (Internal use only)

Happens to all weapon types, it's using the CannonArmorHPBonus (and same config value for the other 3 weapons) to modify the deducted SHP. It should use CannonSystemHPBonus instead.

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
Azereiah created this task.Dec 25 2016, 8:57 AM
lancake claimed this task.Jan 2 2017, 2:46 PM
lancake moved this task from New / Unconfirmed to Confirmed on the Workflow Issue Navigation board.
lancake added a subscriber: lancake.

-Confirmed-

lancake edited Tester information (Internal use only). (Show Details)Jan 2 2017, 2:48 PM
lancake changed Last tested (version) from 0.199.353 to 0.199.358.
lancake changed Category from none/unspecified to Control Block System: Weapons.
lancake set First occurrence (version) to 0.199.353.
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the task status from "Open" to "In Queue (Game)".
lancake triaged this task as "High" priority.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
Restricted Application edited projects, added Workflow Game Development; removed Workflow Issue Navigation. · View Herald TranscriptJan 2 2017, 2:48 PM
Restricted Application added a subscriber: AndyP. · View Herald Transcript
lancake changed the task status from "In Queue (Game)" to "Resolved".Jan 2 2017, 2:59 PM

Make sure to check if System Structure HP Bonus effects still work (they should do what the armor HP bonus did in this bug)

lancake added a commit: Restricted Diffusion Commit.Jan 2 2017, 3:00 PM

Make sure to check if System Structure HP Bonus effects still work (they should do what the armor HP bonus did in this bug)

Just checked. CannonSystemHPBonus does not work.

https://youtu.be/lkBwCP3k25w

Make sure to check if System Structure HP Bonus effects still work (they should do what the armor HP bonus did in this bug)

Just checked. CannonSystemHPBonus does not work.

https://youtu.be/lkBwCP3k25w

Yeah I know since the game was using the ArmorHPBonus instead ^^ This was meant for any tester doing QA. The fix isn't in a dev build yet.

lancake closed this task as "Closed".Tue, Feb 7, 3:09 PM

-QA Testing-

Still is fine since last time I checked, no surprise there.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptTue, Feb 7, 3:09 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake changed Last tested (version) from 0.199.358 to 0.199.435.Tue, Feb 7, 3:09 PM