Starmade | Tooltip doesn't update for single stack items <-> multi slot | meta-item interaction
Closed, FinishedPublic

Description

So i found this had started 1 update ago, when i was looking in my personal cargo in errant venture, but after the update i thought it would be fixed but no its worse,
I also found that last update you can partially fix it for one block if you move it, but now it doesnt work like that

Details

Commits
Restricted Diffusion Commit
Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.199.625
Category
Ingame GUI/HUD
First occurrence (version)
0.199.158
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce
  1. have a salvage computer stack
  2. have a multi slot stack
  3. swap both with each other

Tooltip should still be fine for both

  1. swap them back

Tooltip displays salvage computer for both

Tester information (Internal use only)

It doesn't clear the tooltip from single stack blocks, including meta items.

If you drag another single stack on a spot that had a single stack on it (same goes if you swap items instead), it's fine and it refreshes.
If you drag a multi slot on that spot, it will keep using the old text.

Sometimes it refreshes correctly though... However if you swap single items with multi slots, then swap them back. Both of them will display the hover text of the single stack.

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
squirttle123 added a comment.EditedAug 15 2016, 11:26 PM

ok so i took 3 picts when i reproduced this bug
it was when moving cargo:

so i took those in order

and here are another 2

after shift clicking them over

SmilingDemon shifted this object from the S1 Public space to the S3 Starmade space.
SmilingDemon triaged this task as "Low" priority.
SmilingDemon changed the visibility from "Custom Policy" to "Public (No Login Required)".
SmilingDemon changed the edit policy from "Task Author" to "Starmade (Project)".

-validated-

something isnt being updated fast enough .. couldnt reproduce in Singleplayer so far

its only happened in multiplayer when actually moving cargo from one entity to another

lancake claimed this task.Aug 21 2016, 9:30 AM
lancake moved this task from Open / Validated to Confirmed on the Issue Navigation board.
lancake added subscribers: SmilingDemon, lancake.

-confirmed-

It doesn't clear old hover text data from *single* block stack types, including meta items.

If you drag another single block stack type on it, it's fine and it refreshes.
If you drag a multi slot on that spot, it will keep using the old text.

Sometimes it refreshes correctly, seems to depend on time. However if you swap single items with multi slots, then swap them back. Both of them will display the hover text of the single stack.

lancake changed the title from "When viewing slots in connected personal storage, you will not see the proper tag" to "Tooltip doesn't update for single stack items <-> multi slot interaction".Aug 21 2016, 9:34 AM
lancake edited Steps to reproduce. (Show Details)
lancake edited Tester information (Internal use only). (Show Details)
lancake changed Affected Gamemode(s) from none/unspecified to Single and Multi.
lancake changed Reproducible from uncertain to Yes.
lancake changed Last tested (version) from Latest to 0.199.161.
lancake set First occurrence (version) to 0.199.158.
lancake changed the task status from "Open" to "In Queue (Game)".
Restricted Application edited projects, added Game Development; removed Issue Navigation. · View Herald TranscriptAug 21 2016, 9:35 AM

ok i think i figured out another part, ive been switching between my own personal inv and one thats on my ship while moving cargo and it did it again but this time instead of just thru the ship to another ship it stayed thru to my block storage items
soo....

lancake edited Tester information (Internal use only). (Show Details)Oct 8 2016, 5:10 PM
lancake edited Steps to reproduce. (Show Details)
lancake changed the title from "Tooltip doesn't update for single stack items <-> multi slot interaction" to "Tooltip doesn't update for single stack items <-> multi slot | meta-item interaction ".Oct 8 2016, 5:14 PM
AndyP changed the task status from "In Queue (Game)" to "In Queue".Mar 10 2017, 5:21 PM
Restricted Application added a project: GUI/HUD. · View Herald TranscriptMar 10 2017, 5:21 PM
AndyP moved this task from Backlog / Unclassed to Alpha on the GUI/HUD board.Mar 15 2017, 2:01 PM
lancake edited Steps to reproduce. (Show Details)Jun 8 2017, 6:59 PM
lancake changed the task status from "In Queue" to "Resolved" by committing Restricted Diffusion Commit.Jun 10 2017, 3:48 PM
Restricted Application added a project: Quality Assurance. · View Herald TranscriptJun 10 2017, 3:48 PM
dsample removed a subscriber: dsample.Jun 10 2017, 5:52 PM

-QA Testing-

Fix confirmed.

lancake changed Last tested (version) from 0.199.161 to 0.199.625.Jun 30 2017, 11:12 AM
lancake closed this task as "Closed".Jul 7 2017, 12:34 PM
Restricted Application removed a project: Quality Assurance. · View Herald TranscriptJul 7 2017, 12:34 PM