Starmade | Crash on startup - /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found
Closed, FinishedPublic

Description

[2016-06-16 01:02:25] Exception in thread "main" 
[2016-06-16 01:02:25] java.lang.UnsatisfiedLinkError: /home/starmade/starmade/StarMade/native/linux/libStarMadeNative64.so: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/starmade/starmade/StarMade/native/linux/libStarMadeNative64.so)
[2016-06-16 01:02:25] 	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
[2016-06-16 01:02:25] 	at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
[2016-06-16 01:02:25] 	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
[2016-06-16 01:02:25] 	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1880)
[2016-06-16 01:02:25] 	at java.lang.Runtime.loadLibrary0(Runtime.java:849)
[2016-06-16 01:02:25] 	at java.lang.System.loadLibrary(System.java:1088)
[2016-06-16 01:02:25] 	at obfuscated.QR.a(SourceFile:64)
[2016-06-16 01:02:25] 	at org.schema.game.common.Starter.main(SourceFile:920)

Details

Commits
Restricted Diffusion Commit
Restricted Diffusion Commit
Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.199.132a
Category
Engine
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Tester information (Internal use only)

reopening , not fixed for 32bit OS

https://starmadedock.net/threads/critical-issue-after-new-update-linux.26209/#post-301814

Testing from 0.199.132a

According to feedback looks like the issue still exists for the i386 arch

I finally took a look at the objects, and they are indeed bound against different symbol sets.

objdump -p libStarMadeNative64.so

libStarMadeNative64.so: file format elf64-x86-64

Program Header:
...

Dynamic Section:

NEEDED               libm.so.6
NEEDED               libc.so.6
NEEDED               ld-linux-x86-64.so.2

...

Version References:

required from ld-linux-x86-64.so.2:
  0x0d696913 0x00 05 GLIBC_2.3
required from libm.so.6:
  0x09691a75 0x00 03 GLIBC_2.2.5
required from libc.so.6:
  0x06969194 0x00 07 GLIBC_2.14
  0x09691974 0x00 06 GLIBC_2.3.4
  0x0d696914 0x00 04 GLIBC_2.4
  0x09691a75 0x00 02 GLIBC_2.2.5

objdump -p libStarMadeNative.so

libStarMadeNative.so: file format elf32-i386

Program Header:
...

Dynamic Section:

NEEDED               libstdc++.so.6
NEEDED               libm.so.6
NEEDED               libc.so.6

...

Version References:

required from libm.so.6:
  0x0d696911 0x00 08 GLIBC_2.1
  0x0d696910 0x00 06 GLIBC_2.0
required from libstdc++.so.6:
  0x056bafd3 0x00 07 CXXABI_1.3
  0x0bafd178 0x00 04 CXXABI_1.3.8
  0x08922974 0x00 03 GLIBCXX_3.4
required from libc.so.6:
  0x09691f73 0x00 11 GLIBC_2.1.3
  0x09691a74 0x00 10 GLIBC_2.2.4
  0x0d696914 0x00 09 GLIBC_2.4
  0x09691974 0x00 05 GLIBC_2.3.4
  0x0d696910 0x00 02 GLIBC_2.0

we can see from the NEEDED lines that i386 has libstdc++.so.6 but x86_64 has ld-linux-x86-64.so.2 instead. I'm guessing that this was part of the solution for resolve the problem in x86_64. Whatever was done there probably needs to be copied to the i368 build env

AndyP created this task.Jun 15 2016, 11:42 PM

-Validated-
-Confirmed-

Restricted Application removed a project: Issue Navigation. · View Herald TranscriptJun 15 2016, 11:43 PM
Restricted Application changed the task status from "In Queue (Game)" to "Resolved" by committing Restricted Diffusion Commit.Jun 16 2016, 12:39 AM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptJun 16 2016, 12:39 AM
Gimpy added a subscriber: Gimpy.Jun 16 2016, 4:08 PM

Have same bug when starting the game. will not move past 50% in the initial lanch screen and beta launcher crashes straight to desk top

AndyP added a comment.Jun 21 2016, 6:45 PM

should be fixed by the hotfix @Gimpy can you confirm that?

Yes it now runs smooth @AndyP at 120fps but there is no sound :-)

Gimpy added a comment.Jul 14 2016, 6:32 PM

sorry for the late reply. no tried what you suggested still no sound

xarses added a subscriber: xarses.EditedAug 4 2016, 9:48 PM

https://starmadedock.net/threads/critical-issue-after-new-update-linux.26209/#post-301814

Testing from 0.199.132a

According to feedback looks like the issue still exists for the i386 arch

I finally took a look at the objects, and they are indeed bound against different symbol sets.

objdump -p libStarMadeNative64.so

libStarMadeNative64.so:     file format elf64-x86-64

Program Header:
...

Dynamic Section:
  NEEDED               libm.so.6
  NEEDED               libc.so.6
  NEEDED               ld-linux-x86-64.so.2

...

Version References:
  required from ld-linux-x86-64.so.2:
    0x0d696913 0x00 05 GLIBC_2.3
  required from libm.so.6:
    0x09691a75 0x00 03 GLIBC_2.2.5
  required from libc.so.6:
    0x06969194 0x00 07 GLIBC_2.14
    0x09691974 0x00 06 GLIBC_2.3.4
    0x0d696914 0x00 04 GLIBC_2.4
    0x09691a75 0x00 02 GLIBC_2.2.5
objdump -p libStarMadeNative.so

libStarMadeNative.so:     file format elf32-i386

Program Header:
...

Dynamic Section:
  NEEDED               libstdc++.so.6
  NEEDED               libm.so.6
  NEEDED               libc.so.6
...

Version References:
  required from libm.so.6:
    0x0d696911 0x00 08 GLIBC_2.1
    0x0d696910 0x00 06 GLIBC_2.0
  required from libstdc++.so.6:
    0x056bafd3 0x00 07 CXXABI_1.3
    0x0bafd178 0x00 04 CXXABI_1.3.8
    0x08922974 0x00 03 GLIBCXX_3.4
  required from libc.so.6:
    0x09691f73 0x00 11 GLIBC_2.1.3
    0x09691a74 0x00 10 GLIBC_2.2.4
    0x0d696914 0x00 09 GLIBC_2.4
    0x09691974 0x00 05 GLIBC_2.3.4
    0x0d696910 0x00 02 GLIBC_2.0

we can see from the NEEDED lines that i386 has libstdc++.so.6 but x86_64 has ld-linux-x86-64.so.2 instead. I'm guessing that this was part of the solution for resolve the problem in x86_64. Whatever was done there probably needs to be copied to the i368 build env

SmilingDemon changed the task status from "Resolved" to "In Queue (Game)".Aug 5 2016, 6:52 AM
SmilingDemon edited Tester information (Internal use only). (Show Details)
SmilingDemon changed Last tested (version) from 0.198.153 to 0.199.132a.
Restricted Application edited projects, added Game Development; removed Quality Assurance. · View Herald TranscriptAug 5 2016, 6:52 AM
Auburn changed the task status from "In Queue (Game)" to "Resolved" by committing Restricted Diffusion Commit.Dec 10 2016, 4:52 PM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptDec 10 2016, 4:52 PM
AndyP closed this task as "Closed".

Did not get any further replies, nor new reports about this happening.
Assuming it is fixed.

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptFeb 22 2017, 8:40 AM
Restricted Application added a project: Engine. · View Herald TranscriptMar 10 2017, 6:11 PM