Starmade | offensive explosive effect on cannons and beams stops gaining after 10%
Closed, FinishedPublic

Description

For cannons and beams, explosive effect is hardcapped at radius 1 although it is capable of increasing it to radius 10 on paper.

This causes it to reach its max radius after hitting 10% effect ratio and the surrounding blocks will always be hit by normal damage/6

Since this is capped anyway, perhaps the damage that is spread gets affected by the effect ratio and you automatically set it to radius 1.

surrounding damage = damage/6 * effect ratio

Details

Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.199.435
Category
Control Block System: Weapons
First occurrence (version)
0.1836
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
lancake created this task.Jun 28 2015, 12:27 PM
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake changed Category from none/unspecified to Control Block System: Weapons.
lancake changed Affected Gamemode(s) from none/unspecified to Single and Multi.
lancake set First occurrence (version) to 0.1836.
lancake changed Reproducible from uncertain to Yes.
lancake set Last tested (version) to 0.19291 (Dev).
lancake edited a custom field.
lancake edited Serverconfig (server.cfg). (Show Details)
lancake edited Clientconfig (settings.cfg). (Show Details)
lancake added a subscriber: lancake.
Restricted Application added a project: Issue Navigation. · View Herald TranscriptJun 28 2015, 12:27 PM
lancake edited the task description. (Show Details)Jun 28 2015, 12:28 PM
lancake set Task Type to Bug.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
lancake changed the task status from "Open" to "In Queue (Game)".
Restricted Application edited projects, added Game Development, Starmade; removed Issue Navigation. · View Herald TranscriptJun 28 2015, 12:28 PM
Megacrafter127 shifted this object from the S1 Public space to the S3 Starmade space.
Megacrafter127 changed the edit policy from "Starmade (Project)" to "All Users".
Megacrafter127 edited Serverconfig (server.cfg). (Show Details)
Megacrafter127 edited Clientconfig (settings.cfg). (Show Details)
Megacrafter127 removed Megacrafter127 as the assignee of this task.
Megacrafter127 added a subscriber: Megacrafter127.
lancake claimed this task.Sep 21 2015, 10:48 AM
jijiji added a subscriber: jijiji.Dec 13 2016, 1:15 PM

Can I suggest a way to fix it?

lancake changed the task status from "In Queue (Game)" to "Resolved".Jan 25 2017, 3:47 PM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptJan 25 2017, 3:47 PM
lancake closed this task as "Closed".Feb 7 2017, 1:59 PM

-QA Testing-

Now it scales with your explosion effect ratio and appears to work fine on the entities I've tested. Keep in mind that the explosive effect doesn't do damage anymore to the blocks in front and behind (the ones you're going to hit anyway if the weapons penetrates). The damage dealt to the surrounding is still divided by 6 and should technically be 4 now but left it unchanged mostly because explosive effect is already a bit too powerful imo.

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptFeb 7 2017, 1:59 PM
lancake changed Last tested (version) from 0.19291 (Dev) to 0.199.435.Feb 7 2017, 1:59 PM
Restricted Application added a project: CBS: Weapons. · View Herald TranscriptMar 10 2017, 6:31 PM