Starmade | Warp Gate Distance Displays Incorrectly
Resolved, needs quality check / confirm fix, LowPublic

Description

If I try to set a warp gate distance beyond 64 sectors, it tells me "too far, 64 sectors max."

When I upgrade my gate with chambers, it allows me jump further, but if I attempt to overjump now it still tells me "64 sectors max," which is not correct, since it is allowing me to jump beyond 64 sectors.

The gate distance warning does not appear to calculate the change in potential range.

Details

Commits
Restricted Diffusion Commit
Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.201.079
Category
Ingame GUI/HUD
First occurrence (version)
0.200.335
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce

Buff a warp gate with a distance chamber (and just use the free-target for easier testing).

Set the coordinates to 100 100 100, and attempt to jump.

Tester information (Internal use only)

The message starts with Gate Destination too far!, the maximum distance shown is always the default config value and does not account for chambers,
It's only a GUI issue as jumping through a gate still works fine with a boosted warp distance.

Serverconfig (server.cfg)
 <replace this block with the file content, 
but do not remove the first and last line. 
Before using the paste function, mark the area from the 
opening angle bracket to the closing angle bracket>
Clientconfig (settings.cfg)
 <replace this block with the file content, 
but do not remove the first and last line. 
Before using the paste function, mark the area from the 
opening angle bracket to the closing angle bracket>
MacThule created this task.Jun 22 2018, 5:41 AM
lancake claimed this task.Jul 4 2018, 10:01 AM
lancake moved this task from New / Unconfirmed to Confirmed on the Issue Navigation board.
lancake added a subscriber: lancake.

-validated- & -confirmed-

The message starts with Gate Destination too far!, the maximum distance shown is always the default config value and does not account for chambers,
It's only a GUI issue as jumping through a gate still works fine with a boosted warp distance.

lancake shifted this object from the S1 Public space to the S3 Starmade space.Jul 4 2018, 10:02 AM
lancake changed the task status from "Open" to "In Queue".
lancake lowered the priority of this task from "Normal" to "Low".
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake edited Tester information (Internal use only). (Show Details)
lancake changed Last tested (version) from 201.079 to 0.201.079.
lancake changed Category from none/unspecified to Ingame GUI/HUD.
lancake changed First occurrence (version) from unknown to 0.200.335.
Restricted Application edited projects, added Game Development, GUI/HUD; removed Issue Navigation. · View Herald TranscriptJul 4 2018, 10:02 AM
lancake changed the task status from "In Queue" to "Resolved" by committing Restricted Diffusion Commit.Jul 4 2018, 10:03 AM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptJul 4 2018, 10:03 AM

Yes - it was just an UI error, sorry. Is this where UI bugs are reported or should they go elsewhere?

Ah, I just changed the category and lowered the priority, you did fine. UI Bugs belong here as well, this one should be fixed in the latest dev build, 0.201.105 or above.

Sweet - wasn't sure. Thanks for the work!