Starmade | Beam texture doesn't go away after overheating.
Closed, FinishedPublic

Description

Shooting turrets that shoot beams, when the turret overheats, the beam texture stays permanently on.

Video of the bug
https://www.twitch.tv/videos/221553253?t=02h07m28s

Details

Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.201.115
Category
Control Block System: Weapons
First occurrence (version)
0.200.315
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce

Shoot something that shoots beams till it overheats.

Tester information (Internal use only)

Caused by destroying the beam computer when its active. Happens for any beam

Serverconfig (server.cfg)
 <replace this block with the file content, 
but do not remove the first and last line. 
Before using the paste function, mark the area from the 
opening angle bracket to the closing angle bracket>
Clientconfig (settings.cfg)
 <replace this block with the file content, 
but do not remove the first and last line. 
Before using the paste function, mark the area from the 
opening angle bracket to the closing angle bracket>
Top4ce created this task.Jan 23 2018, 6:15 PM
lancake claimed this task.Feb 2 2018, 12:37 PM
lancake moved this task from New / Unconfirmed to Confirmed on the Issue Navigation board.
lancake changed the task status from "Open" to "In Queue".
lancake added a subscriber: lancake.

-validated- & -confirmed-

Caused by destroying the beam computer when its active.

Restricted Application removed a project: Issue Navigation. · View Herald TranscriptFeb 2 2018, 12:37 PM
lancake shifted this object from the S1 Public space to the S3 Starmade space.Feb 2 2018, 12:43 PM
lancake raised the priority of this task from "Normal" to "High".
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake edited Tester information (Internal use only). (Show Details)
lancake changed Affected Gamemode(s) from none/unspecified to Single and Multi.
lancake changed Last tested (version) from 200.315 to 0.200.323.
lancake changed Category from Textures to Control Block System: Weapons.
lancake set First occurrence (version) to 0.200.315.
schema changed the task status from "In Queue" to "Resolved".Jun 28 2018, 2:25 PM
Restricted Application edited projects, added Quality Assurance; removed Game Development. · View Herald TranscriptJun 28 2018, 2:25 PM
Restricted Application added a subscriber: AndyP. · View Herald Transcript
lancake closed this task as "Closed".

-QA Testing-

Fix confirmed.

Restricted Application removed a project: Quality Assurance. · View Herald TranscriptJul 8 2018, 5:36 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake changed Last tested (version) from 0.200.323 to 0.201.115.Jul 8 2018, 5:36 PM