Starmade | Entering a ship from within another ship (Using F1+F8)
Closed, DuplicatePublic

Description

After looking back at this and making the same mistake again, I discovered exactly what the source of my loss of movement was. As it turns out, entering a ship from within another ship that's not in the same docking chain causes the player to loss control of their character until they exit and re-enter the world.

Details

Task Type
Bug
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.200.272
Category
Engine
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Serverconfig (server.cfg)
<replace this block with the file content,
but do not remove the first and last line.
Before using the paste function,
mark the area from the opening angle bracket to the closing angle bracket>
Clientconfig (settings.cfg)
<replace this block with the file content,
but do not remove the first and last line.
Before using the paste function,
mark the area from the opening angle bracket to the closing angle bracket>

Related Objects

Restricted Application added a project: Issue Navigation. · View Herald TranscriptDec 19 2017, 5:32 PM
Restricted Application added a subscriber: AndyP. · View Herald Transcript
YamiHikari changed the title from "When exiting a ship, player loses ability to move and everything spins uncontrollably" to "Entering a ship from within another ship (Using F1+F8)".Dec 28 2017, 4:33 PM
YamiHikari edited the task description. (Show Details)
SmilingDemon shifted this object from the S1 Public space to the S3 Starmade space.
SmilingDemon changed the task status from "Open" to "Feedback".
SmilingDemon lowered the priority of this task from "Pre-Release Quality Assurance" to "Trivial".
SmilingDemon changed the edit policy from "Task Author" to "Starmade (Project)".
SmilingDemon changed Affected Gamemode(s) from none/unspecified to Single and Multi.
SmilingDemon changed Reproducible from uncertain to Yes.
SmilingDemon changed Last tested (version) from 0.200.250 to 0.200.272.
SmilingDemon changed Category from none/unspecified to Engine.
Restricted Application added projects: Starmade, Waiting on Author. · View Herald TranscriptDec 29 2017, 10:00 AM

Did you jump from ship to ship ... and nowhere was a station involved ? (even as dock for one of the ships?)

Restricted Application edited projects, added Customer responded; removed Waiting on Author. · View Herald TranscriptDec 29 2017, 10:01 AM
Restricted Application changed the task status from "Feedback" to "Open". · View Herald Transcript
SmilingDemon changed the task status from "Open" to "Feedback".Dec 29 2017, 10:01 AM
Restricted Application edited projects, added Waiting on Author; removed Customer responded. · View Herald TranscriptDec 29 2017, 10:01 AM
Restricted Application edited projects, added Customer responded; removed Waiting on Author. · View Herald TranscriptDec 29 2017, 10:02 AM
Restricted Application changed the task status from "Feedback" to "Open". · View Herald Transcript
SmilingDemon changed the task status from "Open" to "Feedback".Dec 29 2017, 12:56 PM
Restricted Application edited projects, added Waiting on Author; removed Customer responded. · View Herald TranscriptDec 29 2017, 12:56 PM

That's right. I directly jumped from one ship to another. Neither ship was docked to anything else. I can try it again and see if you need confirmation.

Restricted Application edited projects, added Customer responded; removed Waiting on Author. · View Herald TranscriptDec 29 2017, 1:47 PM
Restricted Application changed the task status from "Feedback" to "Open". · View Herald Transcript

I just tried to replicate the results, with two standalone ship cores, and got another unexpected result:


As you can see, after jumping ship cores the game thinks that I am in both ships simultaneously. If I try entering the ship core I jumped from, I get the error in the second picture. The strangest part is both ship cores moving whenever I move in flight mode in one of them.

Another odd picture:

SmilingDemon changed the visibility from "Custom Policy" to "Public (No Login Required)".Dec 30 2017, 8:13 PM
SmilingDemon removed a project: RC-Report.

Yeah .. ok that sounds like the usual glitches with F1+F8

its not a game feature .. its a Dev/Debug function .. not even an Admin option.

maybe it gets a bit love later on and is made into a Admin feature of some kind

i will merge this to T353 and add the info there

SmilingDemon closed this task as a duplicate of T353: F1+F8 Glitches .Dec 30 2017, 8:22 PM
Restricted Application edited projects, added Engine; removed Customer responded, Issue Navigation. · View Herald TranscriptDec 30 2017, 8:22 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript