Starmade | NPC-000 falling through floor
Closed, RejectedPublic


The first tutorial task is to go to NPC-00.
However, the NPC is spawning in space and repeatedly dropping and respawning.

Renamed from:
Tutorial Immediately Bugged
to better match the problem from title.


Testing Results
Affected Gamemode(s)
Issue Type
First occurrence (version)
Video Card Vendor
Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
There are a very large number of changes, so older changes are hidden. Show Older Changes
byromaniac set First occurrence (version) to 0.19431 (? or the Steam version at today's date).Oct 7 2015, 6:25 PM
byromaniac changed Reproducible from uncertain to Yes.
byromaniac set Last tested (version) to 0.19431 (? or the Steam version at today's date).
byromaniac edited Serverconfig (server.cfg). (Show Details)
byromaniac edited Clientconfig (settings.cfg). (Show Details)
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptOct 7 2015, 6:25 PM
SmilingDemon triaged this task as "Normal" priority.
SmilingDemon added a project: Starmade.
SmilingDemon shifted this object from the S1 Public space to the S3 Starmade space.
SmilingDemon changed the visibility from "Custom Policy" to "Public (No Login Required)".
SmilingDemon changed the edit policy from "Task Author" to "Starmade (Project)".
SmilingDemon set Issue Type to Bug.
SmilingDemon set Category to Engine.
SmilingDemon changed First occurrence (version) from 0.19431 (? or the Steam version at today's date) to 0.19431 .
SmilingDemon changed Reproducible from Yes to uncertain.
SmilingDemon removed Last tested (version).
SmilingDemon set OS-Specific to No.
SmilingDemon set Hardware-Specific to No.
SmilingDemon set Video Card Vendor to uncertain.

i doubt it happens that way. the pre patch release test on this was good. but better save than sorry ;)

SmilingDemon removed SmilingDemon as the assignee of this task.Oct 9 2015, 9:54 PM
SmilingDemon moved this task from Unclassed to Issue affecting current release on the Starmade board.
SmilingDemon added a subscriber: SmilingDemon.
Chandler claimed this task.Oct 9 2015, 11:56 PM

Interesting tutorial. I'm guessing the incident happened before building the ship? i got to the building from scratch, it went smooth. Are you able reproduce it again?

A log from one of those events by Jananton

alot of these lines in there, maybe related ?

[2015-10-11 11:31:07] NOT MATCHED: SpaceStation[ENTITY_SPACESTATION_target00_0_0_0_2080000001_2080000001_2080000001(167)]
[2015-10-11 11:31:07] NOT MATCHED: AICharacter[(ENTITY_CREATURE_1416003647183_1)(226)]
[2015-10-11 11:31:07] NOT MATCHED: PlS[Jananton ; id(7)(1)f(0)]
[2015-10-11 11:31:07] NOT MATCHED: AICharacter[(ENTITY_CREATURE_1415812644569_1)(239)]
[2015-10-11 11:31:07] NOT MATCHED: AICharacter[(ENTITY_CREATURE_1415812677225_5)(236)]

2015-10-11 12-41-52.mp4


I couldn't get it in SP, but could in MP. It seemed like the NPC was pulled with Gravity before the station was rendered and fell thru. But that wouldn't explain the continual loop

Chandler changed the task status from "Open" to "In Queue (Game)".
lancake changed the task status from "In Queue (Game)" to "Resolved".Nov 8 2015, 6:23 PM
lancake added a subscriber: lancake.
Chandler closed this task as "Closed".Nov 21 2015, 4:11 PM

All looks well.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptNov 21 2015, 4:11 PM
AndyP reopened this task as "Open".Dec 4 2015, 11:19 AM
AndyP added a subscriber: AndyP.

Its back again.

Need to make sure we have at least one system where it happens.
(For my computer it does not)

Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptDec 4 2015, 11:19 AM
AndyP changed the title from "Tutorial Immediately Bugged" to "NPC-000 falling through floor".
AndyP edited the task description. (Show Details)
AndyP raised the priority of this task from "Normal" to "Urgent".
AndyP added a subscriber: Chandler.
AndyP added a comment.Dec 4 2015, 11:21 AM

Raising prio:
Tutorial cannot be played on affected computers.

"Play on multiplayer server" is not obvious for a normal user.

Chandler added a comment.EditedDec 4 2015, 3:08 PM

Tried in SP, all good for me.
Tried in MP, All good for me.

Are you saying that you are having this issue Andy? If Not, who? And lets get them on here for feed back..

The problem is, I currently have no one that has it, but happens a lot, and we get a lot of negative steam reviews, because of the NPC-00 falling out of the station.

HerrSticks added a subscriber: HerrSticks.EditedJan 9 2016, 4:38 AM

Sounds exactly like T767, which currently has a low priority. Hopefully more reports on this will draw attention.

This has been a known bug for months now. Shame its still causing negative steam reviews.

AndyP added a comment.Jan 15 2016, 9:56 PM

Well the looping fall through in T767 is a client-server thing, the client lets it fall, and the server states like: no its on position XYZ and did not fall
and in that position the client initiates the falling again.

The NPC00 leaving the station in total and not being set back, means:
the server somehow confirmed the fall and did not revert it, which we cannot yet reproduce in some way.

Chandler removed Chandler as the assignee of this task.

Perhaps they negative reviews people need to be told to post here, so we can this figure out.

AxxiD added a subscriber: AxxiD.Mar 21 2016, 12:37 AM

I had this issue aswell a while ago (like months) but haven't been testing it again since.
My first guess after I read the comments here is that it might be cause by very slow CPUs in combination with playing on a server. (E.g.: I play on an i5-2410M @ 2.3GHz (not great but it works - kind of.))

I might be able to test the tutorial again this week and will report back after I did.

Tested on v 0.19609 and still happen.

Tested on v 0.19609 and still happen.

What are your specs. Internet connection, computer, video adapter, etc?

Windows 7 64-bit
AMD FX(tm)-4130 Quad-Core Processor (4 CPUs), ~3.8GHz
4096MB RAM
NVIDIA GeForce GTX 960

Adapter: nvd3dumx,nvwgf2umx,nvwgf2umx
Driver Version:
Vendor: NVIDIA Corporation
OpenGL Version: 4.5.0 NVIDIA 353.30
Renderer: GeForce GTX 960/PCIe/SSE2

java version "1.8.0_71"
Java <TM> SE Runtime Environment <build 1.8.0_71-b15>
Java HotSpot<TM> 64-Bit Server VM <build 25.71-b15, mixed mode>

In single mode, the internet connection wasn't so bad
And both server.cfg & settings.cfg was the StarMade default one.

T767 is probably related to this as well

hey, umm. i actually have seen several incidents of players who are afk falling through their floor. and they have mass, physics, and all that, along with the spawn shop npc. it seems like you can fall through i dont know how though

lancake closed this task as "Rejected".Sep 8 2016, 9:56 PM
lancake claimed this task.

Old tutorial is gone now. Npc's still have this issue outside the tutorial but that's reported in T767.

Restricted Application removed a project: Workflow Issue Navigation. · View Herald TranscriptSep 8 2016, 9:56 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript

Add Comment