Starmade | Warpgate faction permission issue
Resolved, needs quality check / confirm fix, HighPublic

Description

Warpgates can be linked by non faction members regardless if its factioned or not, I.E

When player 1 factions his warpgate player 2 who is not inside of player 1 faction can unlink or link said factioned warpgate without blowing off the faction module

Steps to reproduce for testers

  1. Make a warpgate
  2. Get player one to faction said warpgate
  3. After its factioned get player 2 to rightclick to mark another warpgate (this one is unfactioned can be factioned but I did not for my test)
  4. Get player 2 to leftclick the warp computer on the factioned warpgate and enter the cords

You will now be able to use it regardless of the fact it was linked by someone who was not inside the faction.

This leads to warpgates on large servers that admins put down to be unlinked and linked to a homebase of a player
or a warpgate of a faction to another factions homebase etc

Details

Commits
Restricted Diffusion Commit
Restricted Diffusion Commit
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
v0.19439
Issue Type
Bug
Category
Control Block System: Functional
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Zackey_TNT added a project: Starmade.
Zackey_TNT shifted this object from the S1 Public space to the Restricted Space space.
Zackey_TNT changed Category from none/unspecified to Control Block System: Functional.
Zackey_TNT changed Affected Gamemode(s) from none/unspecified to Single and Multi.
Zackey_TNT changed Reproducible from uncertain to Yes.
Zackey_TNT set Last tested (version) to v0.1932.
Zackey_TNT changed Video Card Vendor from uncertain to NVIDIA.
Zackey_TNT set Video Card Model to GTX 760.
Zackey_TNT edited Serverconfig (server.cfg). (Show Details)
Zackey_TNT edited Clientconfig (settings.cfg). (Show Details)
Zackey_TNT added a subscriber: Zackey_TNT.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptJul 12 2015, 1:18 AM
Megacrafter127 removed Megacrafter127 as the assignee of this task.
Megacrafter127 added a subscriber: Megacrafter127.

Validated

Megacrafter127 set Issue Type to Bug.Jul 12 2015, 1:50 AM
Megacrafter127 edited a custom field.
Megacrafter127 set OS-Specific to No.
Megacrafter127 set Hardware-Specific to No.
Megacrafter127 edited Serverconfig (server.cfg). (Show Details)
Megacrafter127 edited Clientconfig (settings.cfg). (Show Details)
Megacrafter127 changed the task status from "Open" to "In Queue (Game)".

Confirmed.

Megacrafter127 removed Megacrafter127 as the assignee of this task.Jul 12 2015, 1:50 AM
AndyP claimed this task.Jul 12 2015, 9:03 AM
AndyP reassigned this task from AndyP to Megacrafter127.
AndyP shifted this object from the Restricted Space space to the S1 Public space.
AndyP changed the visibility from "Custom Policy" to "Public (No Login Required)".
AndyP changed the edit policy from "Task Author" to "Starmade (Project)".
Restricted Application changed the task status from "In Queue (Game)" to "Resolved" by committing Restricted Diffusion Commit.Jul 17 2015, 4:54 PM
Restricted Application added a subscriber: AndyP. · View Herald Transcript
micdoodle8 changed the task status from "Resolved" to "In Queue (Game)".Jul 17 2015, 4:55 PM
micdoodle8 added a subscriber: micdoodle8.
micdoodle8 changed the task status from "In Queue (Game)" to "Resolved".
Megacrafter127 changed Last tested (version) from v0.1932 to v0.19361.Aug 5 2015, 6:02 PM
Megacrafter127 closed this task as "Closed".
Megacrafter127 added a subscriber: SmilingDemon.

Fix confirmed, when attempting to set the destination, an error message pops up stating 'invalid faction id', and the destination is not set.
Tested with @SmilingDemon on the testserver.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptAug 5 2015, 6:04 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
AndyP shifted this object from the S1 Public space to the S3 Starmade space.Aug 11 2015, 11:28 PM
AndyP changed the edit policy from "Starmade (Project)" to "All Users".
AndyP removed Megacrafter127 as the assignee of this task.Aug 22 2015, 10:07 AM

I have an issue with this "fix", I can no longer connect to allied factions. What was wrong with the way it was...If you don't want you computer to be reprogrammed you protect it with a block, no biggie. now nothing works.... out of all the real bugs out there..... you chose this "complaint" why not fix the permission module which is a real issue. AHHH

Could just hand the marker to the allied faction member.

Doesnt work. when a non faction member hold the marker it says unknown, and wont work.

I have an issue with this "fix", I can no longer connect to allied factions. What was wrong with the way it was...If you don't want you computer to be reprogrammed you protect it with a block, no biggie. now nothing works.... out of all the real bugs out there..... you chose this "complaint" why not fix the permission module which is a real issue. AHHH

Intended.
Before hand faction permission was completely ignored.
If you want to so bad simply faction it to yourself...

Ally should have no problem with that

lancake changed the title from "Warpgate faction issue" to "Warpgate faction permission issue".Sep 24 2015, 8:18 AM
lancake reopened this task as "Open".
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptSep 24 2015, 8:18 AM

Needs retesting, confirmation that permissions don't work properly between your faction gate and other stations.

Permission module should allow it for any station, if you're not using this it should allow ally <-> faction maybe but that's not really needed if permission modules work fine

I have an issue with this "fix", I can no longer connect to allied factions. What was wrong with the way it was...If you don't want you computer to be reprogrammed you protect it with a block, no biggie. now nothing works.... out of all the real bugs out there..... you chose this "complaint" why not fix the permission module which is a real issue. AHHH

Intended.
Before hand faction permission was completely ignored.
If you want to so bad simply faction it to yourself...

Ally should have no problem with that

The point is this, i cannot connect my gate to his gate. My station has 5 gates which lead to allies. none now work. I dont thing that my ally wants to make his station mine, sort of the point of having factions..:)

In T400#25207, @lancake wrote:

Needs retesting, confirmation that permissions don't work properly between your faction gate and other stations.

Permission module should allow it for any station, if you're not using this it should allow ally <-> faction maybe but that's not really needed if permission modules work fine

Yeap, we tested the Perms block too, didn't work.. thank you for opening and relooking at it..

Megacrafter127 changed the task status from "Open" to "In Queue (Game)".EditedSep 27 2015, 8:53 AM

-Confirmed-
The faction permission module does not disable the faction-protection of an adjacent warpgate-computer's destination-setting. Whether or not the player attempting to change them is and admin or not had no visible influence on the behaviour, even if admins were permitted to bypass faction-restrictions in the server.cfg.

Megacrafter127 changed Last tested (version) from v0.19361 to v0.19439.Sep 27 2015, 8:54 AM
Megacrafter127 changed Video Card Vendor from NVIDIA to uncertain.
Megacrafter127 removed Video Card Model.
lancake raised the priority of this task from "High" to "Release Blocker".
lancake lowered the priority of this task from "Release Blocker" to "Urgent".
lancake lowered the priority of this task from "Urgent" to "High".
micdoodle8 changed the task status from "In Queue (Game)" to "Resolved".Oct 2 2015, 12:13 AM
Restricted Application added a commit: Restricted Diffusion Commit.Oct 2 2015, 12:52 AM

Add Comment