Starmade | Defensive Ion Effect Not Affecting Docked Entities
Closed, FinishedPublic


The defensive ion effect doesn't protect docked entities. Not sure if this a bug or intended, but this way the main ship's defensive ion can be nullified by simply targeting its docked entities. This turns shield sharing into a disadvantage.


Testing Results
Affected Gamemode(s)
Single and Multi
Last tested (version)
0.19602 (Dev)
Issue Type
Control Block System: Functional
First occurrence (version)
Video Card Vendor
Steps to reproduce

Dock something to an ion affect ship
Shoot at it
Watch how the mother ship loses shields faster when you shoot at the docked stuff then it does if you shoot directly at the ship.

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
Malacodor changed Category from none/unspecified to Control Block System: Rails/Docking.
Malacodor edited Serverconfig (server.cfg). (Show Details)
Malacodor edited Clientconfig (settings.cfg). (Show Details)
Malacodor changed Affected Gamemode(s) from none/unspecified to Single and Multi.
Malacodor changed Reproducible from uncertain to Yes.
Malacodor set Last tested (version) to 0.19538.
Malacodor added a subscriber: Malacodor.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptJan 11 2016, 7:41 PM
lancake claimed this task.Jan 19 2016, 8:01 PM
lancake added a subscriber: lancake.

It was intended back when I asked about it but that was before shield sharing, seems to be a good idea to put that in now.

lancake triaged this task as "Low" priority.Jan 19 2016, 8:02 PM
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake set Issue Type to Bug.
lancake changed Category from Control Block System: Rails/Docking to Control Block System: Functional.
lancake set First occurrence (version) to 0.19538.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
Zackey_TNT added a subscriber: Zackey_TNT.

Interesting issue, However, with the recent change to 25% there needs to be some counter balance. This could also promote tactical targeting instead of derping the mother ship itself.

None the less, I shall conduct my testing shortly.

I suggest that either the mass of all docked entities is taken into account for calculating the strength of the ion effect - as long as shield sharing is active! - or that defensive ion on docked entities also affects shared shields (requires fixing of T320/T382).

Zackey_TNT changed the task status from "Open" to "In Queue (Game)".Feb 13 2016, 12:12 AM


Bug confirmed, shields on docked stuff are not covered by ion affect on the mother ship.

Steps to reproduce:

Dock something to an ion affect ship
Shoot at it
Watch how the mother ship loses shields faster when you shoot at the docked stuff then it does if you shoot directly at the ship.

Zackey_TNT changed First occurrence (version) from 0.19538 to 0.19556.Feb 13 2016, 12:13 AM
Zackey_TNT edited Steps to reproduce. (Show Details)
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 6:55 PM
schema added a subscriber: schema.
lancake closed this task as "Closed".Mar 10 2016, 5:00 PM

-QA Testing-

Seems fine, when the ship with ion effect enabled takes damage related to shield sharing, it uses the reduced value.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 10 2016, 5:00 PM
lancake changed Last tested (version) from 0.19538 to 0.19602 (Dev).Mar 10 2016, 5:00 PM

Add Comment