Starmade | Faction permission personal can lock out everyone if owner leaves the faction
Closed, FinishedPublic

Description

Set a factioned entity to personal, with you as owner. When you leave the faction, that entity will still be set to "personal" and you as owner.

However, this causes 2 issues:

  1. You as the original owner can't edit it anymore, it's not your faction.
  2. The faction can't edit it either, they're not the owner

When you leave a faction, your personal things should go with you (or founders could steal stuff from you that way).

A possible fix would be that the "personal" permission overrides the faction signature. If something belongs to another faction yet has "Personal" and you as owner, you can override the faction and edit/remove/use blocks on that ship.

Details

Blocks
Unknown Object (Maniphest Task)
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19552 (Dev)
Issue Type
Bug
Category
Control Block System: Functional
First occurrence (version)
0.19540 (Dev)
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce
  1. Set a ship to "personal"
  2. Leave faction (make sure it still has another member in it)
  3. Try to use that ship, you can't, Faction members can't use it either
Tester information (Internal use only)

You can reset the faction signature now, but if it is docked to something else (like a homebase),it will inherit that faction signature and still prevent you from using the ship.

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
lancake created this task.Jan 6 2016, 10:49 PM
lancake edited Serverconfig (server.cfg). (Show Details)
lancake edited Clientconfig (settings.cfg). (Show Details)
lancake added a subscriber: lancake.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptJan 6 2016, 10:49 PM
lancake edited the task description. (Show Details)Jan 6 2016, 11:13 PM
lancake triaged this task as "Pre-Release Quality Assurance" priority.
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake set Issue Type to Bug.
lancake set Category to Control Block System: Functional.
lancake set First occurrence (version) to 0.19540 (Dev).
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
lancake set Affected Gamemode(s) to Single and Multi.
lancake set Reproducible to Yes.
lancake set Last tested (version) to 0.19540 (Dev).
lancake edited Steps to reproduce. (Show Details)
Restricted Application added a subscriber: AndyP. · View Herald TranscriptJan 6 2016, 11:13 PM
lancake claimed this task.Jan 6 2016, 11:13 PM

-Confirmed-

lancake moved this task from Open / Validated to Confirmed on the Workflow Issue Navigation board.
lancake changed the task status from "Open" to "In Queue (Game)".
schema changed the task status from "In Queue (Game)" to "Resolved".Jan 7 2016, 4:52 PM
schema added a subscriber: schema.

Owner should now always be able to access owned entities, even after leaving the faction

lancake changed the task status from "Resolved" to "In Queue (Game)".Jan 7 2016, 5:09 PM
lancake removed a subscriber: schema.
lancake changed the task status from "In Queue (Game)" to "Resolved".Jan 9 2016, 11:44 AM

-QA Testing-

2 issues remaining:

  • If the original owner is in no faction at all, he can't open the faction module: "You have to be in a faction to activate this ..."

He should be able to do this: "reset faction signature" would reset the old faction to neutral. "enter faction signature" would either be gray-ed out, or also reset it to neutral.

  • If the original owner is in a new faction, he can open it but pressing either the "reset faction signature" or "enter faction signature" does nothing besides closing the menu.
lancake changed the task status from "Resolved" to "In Queue (Game)".Jan 9 2016, 7:31 PM
lancake edited Tester information (Internal use only). (Show Details)
schema changed the task status from "In Queue (Game)" to "Resolved".Jan 11 2016, 12:13 PM
schema added a subscriber: schema.
lancake changed the task status from "Resolved" to "In Queue (Game)".Jan 14 2016, 9:48 PM

-QA Testing-

Something new popped up:

  1. Setting something to personal locks the owner out too. Can't test out the remaining issues because of it.
  1. Owner is confusing to read


Having the entity name visible seems like a bad idea. The owner of an entity is not the entity itself, the owner here is between <> but it should be shown first. Having the faction next to it in brackets is fine.

lancake changed Last tested (version) from 0.19540 (Dev) to 0.19544 (Dev).Jan 14 2016, 9:48 PM
lancake edited Tester information (Internal use only). (Show Details)
lancake mentioned this in Unknown Object (Maniphest Task).Jan 14 2016, 9:52 PM
lancake added a blocking task: Unknown Object (Maniphest Task).
lancake removed a blocking task: Unknown Object (Maniphest Task).
lancake added a blocked task: Unknown Object (Maniphest Task).
schema changed the task status from "In Queue (Game)" to "Resolved".Jan 14 2016, 10:58 PM

owner was set to the ship not the player

AndyP changed the task status from "Resolved" to "In Queue (Game)".Jan 15 2016, 4:42 PM

-QA Testing-

Not fixed.

However, dialog to reset faction does show up, but clicking OK does nothing.

[2016-01-15 17:41:23] [SERVER] received object faction change request 0 for object Ship[Lancake2_1452078330479](1631)

Server seems to receive the request.
Nothing in client logs

AndyP edited Tester information (Internal use only). (Show Details)Jan 15 2016, 4:45 PM

-QA Testing-

You can reset the faction signature now, but if it is docked to something else (like a homebase),it will inherit that faction signature and still prevent you from using the ship.

lancake edited Tester information (Internal use only). (Show Details)Jan 15 2016, 6:49 PM
schema changed the task status from "In Queue (Game)" to "Resolved".Jan 15 2016, 7:54 PM

-QA Testing-

You can reset the faction signature now, but if it is docked to something else (like a homebase),it will inherit that faction signature and still prevent you from using the ship.

The game will prevent you from resetting the faction signature if it is still docked to something that will causes inheriting issues, and lock you out. You need to undock first before you're able to do that. Have yet to check this system in detail though.

lancake closed this task as "Closed".Jan 29 2016, 2:01 PM

Fix confirmed.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptJan 29 2016, 2:01 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake changed Last tested (version) from 0.19544 (Dev) to 0.19552 (Dev).Jan 29 2016, 2:01 PM

Add Comment