Starmade | Multislot ITEM LOST at Ship Deconstruction by Shipyard with Storage
Closed, FinishedPublic

Description

  1. Prepare a ship that contains any set of multislot items.
  2. Prepare a shipyard with enough storages.
  3. Deconstruct the ship at the shipyard.
  4. Check contents in the storages.
  5. Multislot items are found lost.

Many thanks.

Details

Commits
Restricted Diffusion Commit
Restricted Diffusion Commit
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
No
Last tested (version)
0.19437 (Dev)
Issue Type
Bug
Category
Control Block System: Shipyards
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
oliwehr_sds changed Category from none/unspecified to Engine.
oliwehr_sds changed Affected Gamemode(s) from none/unspecified to Single and Multi.
oliwehr_sds set First occurrence (version) to 0.19431.
oliwehr_sds changed Reproducible from uncertain to Yes.
oliwehr_sds set Last tested (version) to 0.19431.
oliwehr_sds edited Serverconfig (server.cfg). (Show Details)
oliwehr_sds edited Clientconfig (settings.cfg). (Show Details)
oliwehr_sds added a subscriber: oliwehr_sds.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptSep 15 2015, 9:31 AM
oliwehr_sds set Issue Type to Bug.Sep 15 2015, 9:38 AM
oliwehr_sds changed Affected Gamemode(s) from Single and Multi to none/unspecified.
oliwehr_sds removed First occurrence (version).
oliwehr_sds set OS-Specific to No.
oliwehr_sds set Hardware-Specific to No.
oliwehr_sds set Video Card Vendor to uncertain.
AndyP claimed this task.Sep 17 2015, 10:49 PM
AndyP triaged this task as "High" priority.
AndyP shifted this object from the S1 Public space to the S3 Starmade space.
AndyP changed the visibility from "Custom Policy" to "Public (No Login Required)".
AndyP changed the edit policy from "Task Author" to "Starmade (Project)".
AndyP changed Affected Gamemode(s) from none/unspecified to Single and Multi.
AndyP changed Reproducible from Yes to uncertain.
Restricted Application added a subscriber: AndyP. · View Herald TranscriptSep 17 2015, 10:50 PM
AndyP removed AndyP as the assignee of this task.

-Validated-

Zackey_TNT added a subscriber: Zackey_TNT.

Claiming.

Zackey_TNT changed Reproducible from uncertain to No.EditedSep 18 2015, 1:20 PM
Zackey_TNT changed Last tested (version) from 0.19431 to 0.19437 (Dev).
Zackey_TNT moved this task from Open / Validated to Feedback on the Workflow Issue Navigation board.

-Feedback- Unable to reproduce using steps list.

Please test after a sector reload or look into a possible other storage chest these items are going into, Its working fine.

Or provide more info such as

Are you playing on MP?

Are you able to reproduce this affect?

Thank you for your validation.

Firstly, I have to apologize about the discription to reproduce this bug.

The following description was wrong.
"1. Prepare a ship that contains any set of multislot items."

More precise description is as follows.
"1. Prepare a ship with storages that contains any set of multislot items."

Our first series of tests both on SP and MP were in version 0.19431.
Today, we carried out second series of tests both on SP and MP in version 0.19438 and we could still reproduce this bug in 0.19438.

Best regards.

AndyP added a comment.Sep 20 2015, 2:01 PM

Oh, so you are talking about stuff that is stored in storages on the ship you deconstruct?

Like that core with chest and contents in chest was docked to a shipyard and then deconstructed?

Well, this may be something that is not covered by the system, as the transition design->real ship is meant to destroy all container contents.

Thanks for your reply.

Oh, so you are talking about stuff that is stored in storages on the ship you deconstruct?
Like that core with chest and contents in chest was docked to a shipyard and then deconstructed?

Yes.

Well, this may be something that is not covered by the system, as the transition design->real ship is meant to destroy all container contents.

I see. Then, it is strange that non-multislotted items were recovered from the storages as follows.


Rail blocks are existing in the both forms of multislotted and non-multislotted. Number of blocks is 200 (=100+100) for each kind of rail block.


Only non-multislotted blocks were recovered judging from the change in the number of blocks. Number of blocks is 100 for each kind of rail block and less than 200.

Best regards.

Thanks for your helpful replies with this I should hopefully be able to reproduce the affect.

Zackey_TNT changed the task status from "Open" to "In Queue (Game)".EditedSep 21 2015, 5:37 AM

-Confirmed-

I am able to confirm this does happen.

Steps to reproduce:

Deconstruct a ship at a shipyard with storage chests on it that contain multi slot items
?????
Profit

AndyP changed Category from Engine to Control Block System: Shipyards.Oct 26 2015, 10:27 PM
schema changed the task status from "In Queue (Game)" to "Resolved" by committing Restricted Diffusion Commit.Nov 4 2015, 3:17 PM
schema added a commit: Restricted Diffusion Commit.Nov 4 2015, 6:36 PM
Zackey_TNT changed the task status from "Resolved" to "In Queue (Game)".Nov 19 2015, 5:37 AM

-Retesting-

TLDR: Shipyard computers seem to think that it needs five slots to fit a multislot item into its storage, And they don't seem to stack with armor already there unless there is already 5 slots(or more)open

The main fix works multi slot items are confirmed fix and they do dump into the inventories now,

However it would seem that unless there are five available slots (one for each multi item in the stack) it simply spits out four of them and places only one of them into the chest while multi stacked items should only take one slot to fill.

Furthermore if there is already a grey advanced armor block in that single slot the grey advanced multi slot coming from the ship's deconstruction does not stack with it

Example:


schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 3:09 AM
schema added a subscriber: schema.

Irrelevant due to new cargo system

I am really for my absence. I would like to say thank you to everyone. Especially to Zackey_TNT for reproduction, and to schema for drastic modification on the cargo system.

AndyP closed this task as "Closed".Mar 16 2016, 8:49 AM

-QA Testing- (virtual =))

Fix confirmed, system has been replaced.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 16 2016, 8:49 AM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript

Add Comment