Starmade | Using "create docking" on station and planets causes nullpointer
Closed, FinishedPublic

Description

So I went to make a docked entity on a station like you can on the ship yard building. I placed the rail docker on the rail and then went to place the core and when I clicked, I crashed with a null pointer exception.

Details

Commits
Restricted Diffusion Commit
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.1959 (Dev)
Issue Type
Bug
Category
Control Block System: Rails/Docking
First occurrence (version)
v0.19401
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Video Card Model
AMD HD 7800
Steps to reproduce
  1. go into build mode on a station, asteroid, planet
  2. attempt to use create docking
  3. nullpointer occurs
Tester information (Internal use only)

Reopening as it seems to have returned

https://youtu.be/5ThzS8bu0eo

log.txt.0(1)
log.txt.0(2)
log.txt.0(3)

stack thrown on planet and station:

[2016-02-29 19:24:49] [GLFRAME] THROWN: class java.lang.NullPointerException Now Printing StackTrace
[2016-02-29 19:24:49] java.lang.NullPointerException
[2016-02-29 19:24:49] at obfuscated.cZ.i(SourceFile:309)
[2016-02-29 19:24:49] at obfuscated.oh.callback(SourceFile:886)
[2016-02-29 19:24:49] at org.schema.schine.network.client.GUICallbackController.execute(SourceFile:40)
[2016-02-29 19:24:49] at obfuscated.C.updateStateInput(SourceFile:1366)
[2016-02-29 19:24:49] at obfuscated.avp.a(SourceFile:1167)
[2016-02-29 19:24:49] at obfuscated.C.h(SourceFile:2860)
[2016-02-29 19:24:49] at obfuscated.Qy.run(SourceFile:92)

Detected video (Graphicsinfo.txt)

Running on thread: ClientThread
Adapter: aticfx64
Driver Version: 8.17.10.1404
Vendor: ATI Technologies Inc.
OpenGL Version: 4.5.13399 Compatibility Profile Context 15.200.1062.1002
Renderer: AMD Radeon HD 7800 Series
GLSL Ver: 4.40

SMC-Report

Starmade System Checker Report
Fri 08/21/2015
14:45:26.87

RESULTS:
Windows version: Windows ....UNKNOWN
Processor: Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Graphics Card name: AMD Radeon HD 7800 Series ....PASS
Java version: 64-bit Java 8 ....PASS

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
Java Version (64bit)

8_51

thakyZ created this task.Aug 21 2015, 9:49 PM
thakyZ changed Category from none/unspecified to Control Block System: Rails/Docking.
thakyZ changed Affected Gamemode(s) from none/unspecified to Single and Multi.
thakyZ set First occurrence (version) to v0.19401.
thakyZ set Video Card Model to AMD HD 7800.
thakyZ edited Detected video (Graphicsinfo.txt). (Show Details)
thakyZ edited SMC-Report. (Show Details)
thakyZ edited Serverconfig (server.cfg). (Show Details)
thakyZ edited Clientconfig (settings.cfg). (Show Details)
thakyZ edited Java Version (64bit). (Show Details)
thakyZ added a subscriber: thakyZ.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptAug 21 2015, 9:49 PM
lancake claimed this task.Aug 22 2015, 8:33 AM
lancake added a subscriber: lancake.
[2015-08-22 10:29:06] java.lang.NullPointerException
[2015-08-22 10:29:06] 	at obfuscated.gE.a(SourceFile:375)
[2015-08-22 10:29:06] 	at obfuscated.hr.a(SourceFile:395)
[2015-08-22 10:29:06] 	at obfuscated.gU.f(SourceFile:510)
[2015-08-22 10:29:06] 	at obfuscated.gU.a(SourceFile:368)
[2015-08-22 10:29:06] 	at obfuscated.ara.e(SourceFile:759)
[2015-08-22 10:29:06] 	at obfuscated.ara.a(SourceFile:1144)
[2015-08-22 10:29:06] 	at obfuscated.C.h(SourceFile:2731)
[2015-08-22 10:29:06] 	at obfuscated.Lt.run(SourceFile:92)
[2015-08-22 10:29:06] 	at java.lang.Thread.run(Unknown Source)

Full logs: log.txt.0

lancake removed lancake as the assignee of this task.Aug 22 2015, 8:34 AM
lancake claimed this task.
lancake changed the title from "Placing Docking on station though build mode crashes game." to "Using "create docking" on station causes nullpointer".
lancake triaged this task as "High" priority.
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "All Users".
lancake set Issue Type to Bug.
lancake set Reproducible to uncertain.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
Restricted Application added a subscriber: AndyP. · View Herald TranscriptAug 22 2015, 8:35 AM

-Validated-

Shouldn't require a lot of testing to put in queue, has logs and it seems to be limited to static entities only, please check out planets, stations and asteroids.

lancake removed lancake as the assignee of this task.
AndyP claimed this task.Aug 22 2015, 8:53 AM
AndyP moved this task from Open / Validated to Confirmed on the Workflow Issue Navigation board.

-Confirmed-

by Support Ticket

Description (from Ticket):

when using the "Create Docking" tool I am able to place the transparent docking module but when I try to position the core the game freezes every time. also I am placing the docking module on a rail that is connected to my station, if that helps

Log:

[2015-08-21 20:11:09] DRAWING DEBUG: 190000663; ; 0; 19; 663; 
[2015-08-21 20:11:09] [SINGLE_BLOCK_DRAWER] CHECKING FOR ERROR
[2015-08-21 20:11:09] [SHADER] validate: current FBO: 4
[2015-08-21 20:11:25] java.lang.NullPointerException
[2015-08-21 20:11:25] 	at obfuscated.gE.a(SourceFile:375)
[2015-08-21 20:11:25] 	at obfuscated.hr.a(SourceFile:395)
[2015-08-21 20:11:25] 	at obfuscated.gU.f(SourceFile:510)
[2015-08-21 20:11:25] 	at obfuscated.gU.b(SourceFile:670)
[2015-08-21 20:11:25] 	at obfuscated.gU.a(SourceFile:365)
[2015-08-21 20:11:25] 	at obfuscated.ara.e(SourceFile:759)
[2015-08-21 20:11:25] 	at obfuscated.ara.a(SourceFile:1144)
[2015-08-21 20:11:25] 	at obfuscated.C.h(SourceFile:2731)
[2015-08-21 20:11:25] 	at obfuscated.Lt.run(SourceFile:92)
[2015-08-21 20:11:25] 	at java.lang.Thread.run(Unknown Source)
[2015-08-21 20:12:00] [GHOST-OBJECT] SWEEP TEST TIME: 58
AndyP changed the task status from "Open" to "In Queue (Game)".Aug 22 2015, 8:55 AM
schema changed the task status from "In Queue (Game)" to "Resolved" by committing Restricted Diffusion Commit.Sep 1 2015, 1:46 AM
AndyP closed this task as "Closed".Sep 4 2015, 9:41 PM

-QA Testing-

Fix confirmed

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptSep 4 2015, 9:41 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
AndyP removed AndyP as the assignee of this task.Sep 7 2015, 9:05 PM
spunkie reopened this task as "In Queue (Game)".Jan 30 2016, 4:41 AM
spunkie added a subscriber: spunkie.
Restricted Application added a project: Workflow Game Development. · View Herald TranscriptJan 30 2016, 4:41 AM
spunkie claimed this task.Jan 30 2016, 4:41 AM
spunkie changed Reproducible from uncertain to Yes.Jan 30 2016, 4:43 AM
spunkie set Last tested (version) to 0.19554 (Dev).
spunkie edited Steps to reproduce. (Show Details)
spunkie edited Tester information (Internal use only). (Show Details)
SmilingDemon changed the title from "Using "create docking" on station causes nullpointer" to "Using "create docking" on station and planets causes nullpointer".Feb 29 2016, 6:33 PM
SmilingDemon edited Tester information (Internal use only). (Show Details)
SmilingDemon raised the priority of this task from "High" to "Release Blocker".Feb 29 2016, 6:52 PM
schema changed the task status from "In Queue (Game)" to "Resolved".Feb 29 2016, 8:17 PM
schema added a subscriber: schema.

resolved in versions after (but not including) 0.19574

spunkie closed this task as "Closed".Mar 3 2016, 1:25 AM

-QA testing-

Fix confirmed I no longer crash upon attempting to use create docking on planets and asteroids (tested with 100 selection area size).

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 3 2016, 1:25 AM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
spunkie changed Last tested (version) from 0.19554 (Dev) to 0.1959 (Dev).Mar 3 2016, 1:54 AM

Add Comment