Starmade | Server cannot be started because of one collapsed "SIMULATION_STATE.sim"
Closed, FinishedPublic

Description

#1 original report

One day, our server crashed and we could not start it again. The attempts to restart the server by using the launcher always failed. Then, we started deleting some files in the "server-database" folder. Finally, we found that we can start the server again by deleting one file "SIMULATION_STATE.sim".

I would like to put a piece of log around the fail and the cause "SIMULATION_STATE.sim".

We have no precise idea why this file causes the server failure. At least, we found that the attached one was empty while it is usually filled with 34 bytes of Zero.

Thank you.
#1.1
I found I made a wrong statement "while it is usually filled with 34 bytes of Zero". The wrong .sim is filled with 34 bytes of zeros and the proper one is filled with non-zero values. It can be seen in the newly attached files. In addition, we found that the wrong one seems to be generated in a server crash.
A piece of log around the fail Bug #xxxx-log.txt
The cause Bug #xxxx-SIMULATION_STATE.sim
Attempt to start server with wrong "SIMULATION_STATE.sim" Bug #xxxx-log.txt.0
Causes server crash. (34 Bytes) Bug #xxxx-SIMULATION_STATE(NG).sim
Does not cause server crash. (34 Bytes) Bug #xxxx-SIMULATION_STATE(OK).sim
#2
Supplied Bug #xxxx-SIMULATION_STATE(NG).sim causes a crash of the game as described.

Java is not beeing terminated, so restart after the crash wasnt possible either without killing the java task.
Deleting the similation_state.sim file lets you restart the game.
dedicated server + connect of a client did work again after that.
The file wasnt recreated on start or login but on logout.

Details

Testing Results
Affected Gamemode(s)
Serverside
Reproducible
Yes
Last tested (version)
0.19602 (DEV)
Issue Type
Bug
Category
Engine
First occurrence (version)
0.1917
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
SmilingDemon changed Category from none/unspecified to Engine.
SmilingDemon changed Affected Gamemode(s) from none/unspecified to Serverside.
SmilingDemon set First occurrence (version) to 0.1917.
SmilingDemon changed Reproducible from uncertain to Yes.
SmilingDemon set Last tested (version) to 0.1919.
SmilingDemon edited a custom field.
SmilingDemon edited Serverconfig (server.cfg). (Show Details)
SmilingDemon edited Clientconfig (settings.cfg). (Show Details)
SmilingDemon added a subscriber: SmilingDemon.
SmilingDemon changed the task status from "Open" to "In Queue (Game)".Jun 20 2015, 9:45 AM
AndyP changed the title from " Server cannot be started because of one collapsed "SIMULATION_STATE.sim" " to "Server cannot be started because of one collapsed "SIMULATION_STATE.sim" ".Aug 11 2015, 11:12 PM
AndyP shifted this object from the S1 Public space to the S3 Starmade space.
AndyP changed the edit policy from "Starmade (Project)" to "All Users".
AndyP set Issue Type to Bug.
AndyP set OS-Specific to No.
AndyP set Hardware-Specific to No.
AndyP set Video Card Vendor to uncertain.
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 7:57 PM
schema added a subscriber: schema.
SmilingDemon closed this task as "Closed".Mar 10 2016, 11:27 AM

-QA Testing-
can now start the server with the supplied broken file.

fixed then i guess

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 10 2016, 11:27 AM
SmilingDemon changed Last tested (version) from 0.1919 to 0.19602 (DEV).Mar 10 2016, 11:28 AM

Add Comment