Starmade | overheating fleet ships can't be salvaged
Confirmed task for Starmade game development, NormalPublic

Description

If a fleet member overheats, it will still try to stay in formation, follow you around etc.

Details

Testing Results
Affected Gamemode(s)
Singleplayer
Reproducible
Yes
Last tested (version)
0.199.171
Issue Type
Bug
Category
Fleets
First occurrence (version)
0.199.161
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce
  1. overheat a fleet ship
  2. try to salvage
Tester information (Internal use only)

Overheating fleet ships can't be salvaged. Only when they're removed from the fleet it works again.
Removing the fleet entirely (delete fleet) doesn't solve it though! You have to remove the overheating member separately from the fleet or you still won't be able to salvage it.

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
lancake created this task.Feb 14 2016, 2:58 PM
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed Category from none/unspecified to Fleets.
lancake edited Serverconfig (server.cfg). (Show Details)
lancake edited Clientconfig (settings.cfg). (Show Details)
lancake edited Steps to reproduce. (Show Details)
lancake added a subscriber: lancake.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptFeb 14 2016, 2:58 PM
Restricted Application added a subscriber: AndyP. · View Herald Transcript
lancake changed the edit policy from "Task Author" to "Starmade (Project)".Feb 14 2016, 3:04 PM
lancake set Issue Type to Bug.
lancake set First occurrence (version) to 0.19557 (Dev).
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
lancake set Affected Gamemode(s) to Singleplayer.
lancake set Reproducible to Yes.
lancake set Last tested (version) to 0.19557 (Dev).
lancake claimed this task.Feb 14 2016, 11:21 PM
lancake moved this task from New / Unconfirmed to Confirmed on the Workflow Issue Navigation board.
lancake changed the task status from "Open" to "In Queue (Game)".Feb 14 2016, 11:33 PM

-Confirmed-

schema changed the task status from "In Queue (Game)" to "Resolved".Feb 27 2016, 12:18 AM
schema added a subscriber: schema.
SmilingDemon changed Last tested (version) from 0.19557 (Dev) to 0.19564 (DEV).
SmilingDemon changed the task status from "Resolved" to "In Queue (Game)".Feb 27 2016, 4:05 PM

-QA Testing-

no change here

did overheat a ship out of 5 in a fleet and then ordered the fleet to move somewhere ... all 5 ships did move out to execute that order

not fixed - no change

SmilingDemon edited Tester information (Internal use only). (Show Details)Feb 27 2016, 4:06 PM
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 1 2016, 7:10 PM
SmilingDemon closed this task as "Closed".Mar 2 2016, 10:30 PM

-QA Testing-
Fixed

Overheating ship continues to be listed as part of the fleet but is no longer moving around with it when the fleet get an order.
After it unspawns due top being overheated it gets removed from the fleet.
and after reboot of a overheated ship it continues to execute fleet orders

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 2 2016, 10:30 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake reopened this task as "In Queue (Game)".Aug 27 2016, 9:26 PM
lancake moved this task from Archived to Issue affecting current release on the Starmade board.

Re-opening.

Overheating fleet ships can't be salvaged. Only when they're removed from the fleet it works again.
Removing the fleet entirely (delete fleet) doesn't solve it though! You have to remove the overheating member separately from the fleet or you still won't be able to salvage it.

Restricted Application added a project: Workflow Game Development. · View Herald TranscriptAug 27 2016, 9:26 PM
lancake changed the title from "overheating fleet ships are still AI controlled" to "overheating fleet ships can't be salvaged".Aug 27 2016, 9:27 PM
lancake lowered the priority of this task from "Pre-Release Quality Assurance" to "Normal".
lancake changed Last tested (version) from 0.19564 (DEV) to 0.199.171.
lancake changed First occurrence (version) from 0.19557 (Dev) to 0.199.161.
lancake edited Steps to reproduce. (Show Details)
lancake edited Tester information (Internal use only). (Show Details)

I'm still having this issue. I destroy my enemies and cannot salvage the corpses of their ships. They deserve to be mined.

Add Comment