Starmade | Z-fighting with "preview block to build" enabled while using some build tools
Closed, FinishedPublic

Description

May related to T925 ; with some blocks the yellowish overlay cause some transparency issue in build mode with the remove mode cursor. We can see background like if there were a hole in the structure (i.e. black hull block).

Here a gif :

And fews pictures :


But it don't seems affect all blocks (i.e. the white hull block).

I didn't took screen but blocks like small cactus render like disappear when overlay by the remove cursor (we don't see the object inside the cube).

Details

Testing Results
Affected Gamemode(s)
Multiplayer
Reproducible
Yes
Last tested (version)
0.19602 (Dev)
Issue Type
Bug
Category
Engine
First occurrence (version)
0.19556
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
NVIDIA
Video Card Model
GeForce GTX 960
Steps to reproduce
  1. Place a few blocks down
  2. Enable "preview block to build"
  3. Use remove, copy/paste or a build helper mode
  4. Hover over the blocks you placed while having a block selected on your hotbar
  5. You'll see Z-fighting occurring
Tester information (Internal use only)

You only get this when using "Preview block to build". It basically still renders "preview block to build" which is transparent. But since it renders above another block in this case, you get Z-fighting.

Fix should be to disable Preview block to build when using remove, copy/paste and build helper mode.

Detected video (Graphicsinfo.txt)

Running on thread: ClientThread
Adapter: nvd3dumx,nvwgf2umx,nvwgf2umx
Driver Version: 10.18.13.5330
Vendor: NVIDIA Corporation
OpenGL Version: 4.5.0 NVIDIA 353.30
Renderer: GeForce GTX 960/PCIe/SSE2
GLSL Ver: 4.50 NVIDIA

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
C_USE_NEW_PLAYER_MODEL_ = true
CONTROL_HELP = false
C_MOUSE_BUTTOM_SWITCH = false
G_RESOLUTION = 1920 x 1080
G_FULLSCREEN = true
G_VSYNCH = false
G_FOV = 110.0
G_MAX_SEGEMENTSDRAWN = 8000
G_DRAW_SURROUNDING_GALAXIES_IN_MAP = false
HIT_INDICATION_NUMBERS_LIFETIME = 0.6
D_LIFETIME_NORM = 30
G_WINDOWED_BORDERLESS = false
S_SOUND_SYSTEM_ENABLED = true
S_SOUND_ENABLED = true
S_SOUND_VOLUME_GLOBAL = 10
N_TRANSMIT_RAW_DEBUG_POSITIONS = false
C_SELECTED_JOYSTICK = 0
ICON_BAKERY_BLOCKSTYLE_ROTATE_DEG = -90.0
MOUSE_WHEEL_SENSIBILITY = 7.0E-4
BUILD_MODE_SHIFT_SPEED = 25.0
ORBITAL_CAM_SPEED = 0.5
G_DAMAGE_DISPLAY = 600
G_STAR_COUNT = 4096
G_VBO_BULKMODE_SIZE = 4
G_DRAW_FOG = false
G_DRAW_BEAMS = true
G_DRAW_EXHAUST_PLUMS = true
D_INFO_CONTROLMANAGER = false
D_INFO_SHADER = true
T_ENABLE_TEXTURE_BAKER = false
D_INFO_DRAW_TIMES = false
D_INFO_DRAW_SPACE_PARTICLE = false
G_SPACE_PARTICLE = true
G_DRAW_MOUSE_COLLISION = false
G_ATMOSPHERE_SHADER = normal
G_SHADOW_QUALITY = ULTRA
G_DRAW_SHIELDS = true
G_DRAW_WATER = true
G_DRAW_BACKGOUND = true
G_WATER_USER_MIPMAPS = false
E_NAVIGATION_FILTER = 869
G_DRAW_ENTITIES = true
G_FRUSTUM_CULLTING = true
G_DRAW_EFFECTS = true
G_SHADER_RELOAD = false
G_FRAMRATE_FIXED = -1
G_SHADERS_ACTIVE = true
G_DEBUG_DRAW_GRID = false
G_DEBUG_DRAW_LINES = true
F_FRAME_BUFFER_USE = false
T_TERRAIN_DRAW = true
T_TERRAIN_WIREFRAME_DRAW = false
G_CULLING_ACTIVE = true
G_TEXTURE_ARRAYS = false
G_AUTO_NORMALIZATION = true
G_DRAW_BY_SIDES = true
G_WIREFRAMED = false
G_NORMAL_MAPPING = false
G_TEXTURE_COMPRESSION_BLOCKS = false
G_TEXTURE_ARRAY_COMPRESSION = true
G_TEXTURE_ARRAY_MIPMAP = true
G_TEXTURE_MIPMAP = true
G_SHADOWS = true
G_SHADOWS_VSM = false
S_PAUSED = false
S_SETTINGS_SHOW = false
MINIMAP_MODE = SMALL
SECTOR_INDICATION_MODE = INDICATION_ONLY
S_KEY_ALLOW_DUPLICATES = true
G_PROD_BG = true
G_PROD_BG_QUALITY = 4096
G_TEXTURE_PACK = Default
GIF_WIDTH = 640
GIF_HEIGHT = 640
GIF_FPS = 15
GIF_GUI = false
G_DEBRIS_THRESHOLD_MS = 4
G_TEXTURE_PACK_RESOLUTION = 256
S_INITIAL_SETTING = Multi Player
S_GAME_MODE = Sandbox
G_BONE_ANIMATION = true
P_NT_DEBUG_ACTIVE = false
P_PHYSICS_DEBUG_ACTIVE_OCCLUSION = false
P_PHYSICS_DEBUG_ACTIVE = false
P_PHYSICS_DEBUG_MODE = 0
G_DEUBG_LINE_DRAWING_ACTIVATED = false
G_WINDOW_START_POSITION = center
G_DRAW_GUI_ACTIVE = true
G_DRAW_NO_OVERLAYS = false
G_PARTICLE_SORTING = true
P_PHYSICS_ACTIVATED = true
G_SMOKE_QUALITY = false
G_DRAW_STARS = true
G_DRAW_PASTE_PREVIEW = true
G_USE_SPRITE_VBO = true
S_TUTORIAL = false
G_AUTOSELECT_CONTROLLERS = true
S_INFO_DRAW = FPS_AND_PING
G_VBO_FLAG = STATIC
N_LAG_COMPENSATION = true
N_IGNORE_SAVED_UPLINK_CREDENTIALS_IN_SINGLEPLAYER = true
N_SERVER_TIME_UPDATE_FREQUENCE = 2000
M_TEXTURE_PACK_CONFIG_TOOL = ./data/textures/block/Default/64/
G_MULTI_SAMPLE = 0
G_MIPMAP_LEVEL_MAX = 3
M_MOUSE_SENSITIVITY = 0.5
G_HIT_INDICATION_SIZE = 1.0
F_BLOOM = true
F_BLOOM_INTENSITY = 0.4
S_MOUSE_LOCK = true
G_DRAW_ADV_BUILDMODE_BLOCK_PREVIEW = true
G_DRAW_ALL_CONNECTIONS = false
G_SHOW_PURE_NUMBERS_FOR_SHIELD_AND_POWER = false
S_FLIP_HOTBAR_MOUSEWHEEL_WITHOUT_CTRL = true
S_ZOOM_MOUSEWHEEL = SLOTS
S_MOUSE_SHIP_INVERT = false
S_MOUSE_ALL_INVERT = false
S_USE_REGION_SIGNATURE_TEST = false
G_PREVIEW_TO_BUILD_BLOCK = true
S_EXIT_ON_ESC = false
G_USE_HIGH_QUALITY_ACKGROUND = true
G_DRAW_POPUPS = true
G_USE_VBO_MAP = true
G_DRAW_JUMP_OVERLAY = true
G_MAG_FILTER_LINEAR_BLOCKS = false
G_MAG_FILTER_LINEAR_GUI = false
G_MAX_BEAMS = 1024
SEGMENT_REQUEST_BATCH = 32
CLIENT_BUFFER_SIZE = 65536
ICON_BAKERY_SINGLE_RESOLUTION = 150
G_RAYTRACE_COUNT = 256
ICON_BAKERY_SINGLE_ICONS = false
G_MUST_CONFIRM_DETACHEMENT_AT_SPEED = 50.0
G_USE_SHADER4 = true
O_OCULUS_RENDERING = false
G_USE_VERTEX_LIGHTING_ONLY = false
CLIENT_TRAFFIC_CLASS = true
G_DRAW_SELECTED_BLOCK_WOBBLE = true
G_USE_TWO_COMPENENT_SHADER = false
A_FORCE_AUTHENTICATION_METHOD = -1
MIN_FFA = 2
B_UNDO_REDO_MAX = 30
N_ARTIFICIAL_DELAY = 0
SEGMENT_PIECE_QUEUE_SINGLEPLAYER = 32767
G_MAX_MISSILE_TRAILS = 128
G_USE_OCCLUSION_CULLING = false
C_AUTOASSIGN_WEAPON_SLOTS = true
G_DRAW_NT_STATS_OVERLAY = false
CLIENT_CUSTOM_TEXTURE_PATH = ./customBlockTextures
SECRET = none
USE_OPEN_AL_SOUND = true
LIMIT_FPS_UNFOCUS = true
GUI_USE_DISPLAY_LISTS = false
USE_GL_MULTI_DRAWARRAYS = true
USE_GL_MULTI_DRAWARRAYS_INITIAL_SET = true
CHAT_CLOSE_ON_ENTER = true
A_FORCE_LOCAL_SAVE_ENABLED_IN_SINGLE_PLAYER = false
G_SHIP_INFO_ZOOM = 0
G_SINGLEPLAYER_CREATIVE_MODE = false
G_DRAW_LAG_OBJECTS_IN_HUD = false
G_SHOW_SYMMETRY_PLANES = true
LANGUAGE_PACK = english
Java Version (64bit)

java version "1.8.0_71"
Java <TM> SE Runtime Environment <build 1.8.0_71-b15>
Java HotSpot<TM> 64-Bit Server <build 25.71-b15, mixed mode>

Croquelune changed Category from none/unspecified to Ingame GUI/HUD.
Croquelune set First occurrence (version) to 0.19556.
Croquelune changed Video Card Vendor from uncertain to NVIDIA.
Croquelune set Video Card Model to GeForce GTX 960.
Croquelune edited Detected video (Graphicsinfo.txt). (Show Details)
Croquelune edited Serverconfig (server.cfg). (Show Details)
Croquelune edited Clientconfig (settings.cfg). (Show Details)
Croquelune edited Java Version (64bit). (Show Details)
Croquelune changed Affected Gamemode(s) from none/unspecified to Multiplayer.
Croquelune changed Reproducible from uncertain to Yes.
Croquelune set Last tested (version) to 0.19556.
Croquelune added a subscriber: Croquelune.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptFeb 4 2016, 12:48 AM
lancake claimed this task.Feb 4 2016, 2:07 PM
lancake added a subscriber: lancake.

-Confirmed-

It's not really a transparency issue here. You only get this when using "Preview block to build". It basically still renders "preview block to build" which is transparent. But since it renders above another block in this case, you get Z-fighting.

Fix should be to disable Preview block to build when using remove, copy/paste and build helper mode.

lancake changed the title from "Transparency overlay cursor issues when Remove Mode" to "Z-fighting with "preview block to build" enabled while using some build tools".Feb 4 2016, 2:10 PM
lancake triaged this task as "Trivial" priority.
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake set Issue Type to Bug.
lancake changed Category from Ingame GUI/HUD to Engine.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake edited Steps to reproduce. (Show Details)
lancake edited Tester information (Internal use only). (Show Details)
lancake moved this task from New / Unconfirmed to Confirmed on the Workflow Issue Navigation board.
lancake changed the task status from "Open" to "In Queue (Game)".
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 5:32 PM
schema added a subscriber: schema.
lancake closed this task as "Closed".Mar 10 2016, 5:53 PM

-QA Testing-

Can only notice some Z-fighting when in construct mode and looking at non cubic blocks, usually it ends up somewhere different but that's another issue, would also belong under the transparency issue task.

Other than that, fix confirmed.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 10 2016, 5:53 PM
lancake changed Last tested (version) from 0.19556 to 0.19602 (Dev).Mar 10 2016, 5:53 PM

Add Comment