Starmade | ArrayIndexOutOfBoundsException on modified planet plate
Closed, FinishedPublic

Description

A Planet plate used because of its gravity to build a spawn area around it was expanded outwards by attaching Asteroid satellites, this causes entities to not spawn. Chunks/entities don't load and there are some other problems.

Serverlog file of my test log.txt.0

[2016-02-01 19:08:23] java.lang.ArrayIndexOutOfBoundsException: -13
[2016-02-01 19:08:23] 	at org.schema.game.common.data.world.SegmentData.getType(SourceFile:811)
[2016-02-01 19:08:23] 	at org.schema.game.common.data.world.SegmentData.getType(SourceFile:917)
[2016-02-01 19:08:23] 	at obfuscated.aoM.a(SourceFile:42)
[2016-02-01 19:08:23] 	at org.schema.game.server.controller.world.factory.terrain.TerrainGenerator.a(SourceFile:723)
[2016-02-01 19:08:23] 	at obfuscated.anO.a(SourceFile:62)
[2016-02-01 19:08:23] 	at obfuscated.anO.a(SourceFile:44)
[2016-02-01 19:08:23] 	at obfuscated.Sn.a(SourceFile:124)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:157)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:253)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:180)
[2016-02-01 19:08:23] 	at org.schema.game.server.controller.GameServerController.a(SourceFile:2023)
[2016-02-01 19:08:23] 	at obfuscated.anf.run(SourceFile:49)
[2016-02-01 19:08:23] 	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
[2016-02-01 19:08:23] 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
[2016-02-01 19:08:23] 	at java.lang.Thread.run(Unknown Source)
[2016-02-01 19:08:23] java.lang.ArrayIndexOutOfBoundsException: -7
[2016-02-01 19:08:23] 	at org.schema.game.common.data.world.SegmentData.getType(SourceFile:811)
[2016-02-01 19:08:23] 	at org.schema.game.common.data.world.SegmentData.getType(SourceFile:917)
[2016-02-01 19:08:23] 	at obfuscated.aoM.a(SourceFile:42)
[2016-02-01 19:08:23] 	at org.schema.game.server.controller.world.factory.terrain.TerrainGenerator.a(SourceFile:723)
[2016-02-01 19:08:23] 	at obfuscated.anO.a(SourceFile:62)
[2016-02-01 19:08:23] 	at obfuscated.anO.a(SourceFile:44)
[2016-02-01 19:08:23] 	at obfuscated.Sn.a(SourceFile:124)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:157)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:253)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:180)
[2016-02-01 19:08:23] 	at org.schema.game.server.controller.GameServerController.a(SourceFile:2023)
[2016-02-01 19:08:23] 	at obfuscated.anf.run(SourceFile:49)
[2016-02-01 19:08:23] 	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
[2016-02-01 19:08:23] 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
[2016-02-01 19:08:23] 	at java.lang.Thread.run(Unknown Source)
[2016-02-01 19:08:23] java.lang.ArrayIndexOutOfBoundsException: -1
[2016-02-01 19:08:23] 	at org.schema.game.common.data.world.SegmentData.getType(SourceFile:811)
[2016-02-01 19:08:23] 	at org.schema.game.common.data.world.SegmentData.getType(SourceFile:917)
[2016-02-01 19:08:23] 	at obfuscated.aoM.a(SourceFile:42)
[2016-02-01 19:08:23] 	at org.schema.game.server.controller.world.factory.terrain.TerrainGenerator.a(SourceFile:723)
[2016-02-01 19:08:23] 	at obfuscated.anO.a(SourceFile:62)
[2016-02-01 19:08:23] 	at obfuscated.anO.a(SourceFile:44)
[2016-02-01 19:08:23] 	at obfuscated.Sn.a(SourceFile:124)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:157)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:253)
[2016-02-01 19:08:23] 	at obfuscated.anc.a(SourceFile:180)
[2016-02-01 19:08:23] 	at org.schema.game.server.controller.GameServerController.a(SourceFile:2023)
[2016-02-01 19:08:23] 	at obfuscated.anf.run(SourceFile:49)
[2016-02-01 19:08:23] 	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
[2016-02-01 19:08:23] 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
[2016-02-01 19:08:23] 	at java.lang.Thread.run(Unknown Source)

the sector causing it
(modified by me to remove docked entities without changing the bug effect)
New-Spawn.smsec

Details

Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19602 (Dev)
Issue Type
Bug
Category
Engine
First occurrence (version)
0.19549
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce
  1. Import the supplied sector somewhere (I did increase the sector size for that)
  2. change sector to import and take a look
  3. the planet plate shouldn't load and your logs show ArrayIndexOutOfBoundsException
Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
SmilingDemon changed Category from none/unspecified to Engine.
SmilingDemon set First occurrence (version) to 019549.
SmilingDemon edited Serverconfig (server.cfg). (Show Details)
SmilingDemon edited Clientconfig (settings.cfg). (Show Details)
SmilingDemon edited Steps to reproduce. (Show Details)
SmilingDemon added a subscriber: SmilingDemon.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptFeb 1 2016, 6:50 PM
lancake claimed this task.Feb 4 2016, 2:28 PM
lancake added a subscriber: lancake.

-Confirmed-

I get it too so pushing in queue.

lancake edited the task description. (Show Details)Feb 4 2016, 2:31 PM
lancake triaged this task as "High" priority.
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake set Issue Type to Bug.
lancake changed First occurrence (version) from 019549 to 0.19549.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
lancake set Affected Gamemode(s) to Single and Multi.
lancake set Reproducible to Yes.
lancake set Last tested (version) to 0.19556.
lancake edited Steps to reproduce. (Show Details)
Restricted Application added a subscriber: AndyP. · View Herald TranscriptFeb 4 2016, 2:31 PM
lancake changed the task status from "Open" to "In Queue (Game)".
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 5:42 PM
schema added a subscriber: schema.
lancake closed this task as "Closed".Mar 10 2016, 5:19 PM

-QA Testing-

Fix confirmed, can load it in again and seems to be completely intact.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 10 2016, 5:19 PM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake changed Last tested (version) from 0.19556 to 0.19602 (Dev).Mar 10 2016, 5:19 PM

Add Comment