Starmade | "View Relations" does not display correct relationship values
Closed, FinishedPublic

Description

It displays "OWN" status for the checking faction, not the faction, relations of which are being displayed. It display "FRIEND" status for the faction in question.

http://i.imgur.com/n4R44T2.png - my faction is "Imaginary Numbers", my enemy is "SM1 Scavengers"
http://i.imgur.com/Uz0qy36.png - I am checking "SM1 Scavengers" faction

Details

Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19602 (Dev)
Issue Type
Bug
Category
Engine
First occurrence (version)
0.19556
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce
  1. Have a faction yourself
  2. Look at someone else's faction
  3. Check your faction in their list and their own faction
Tester information (Internal use only)

The issue is a small inconsistency or mix-up:

  • Your faction appears as "Own" when looking at another faction's relations.
  • That faction appears as "Friend" when looking at its faction's relations.

Your own faction should just appear as any other faction when looking at someone else's faction relation. Which is "Enemy", "Neutral" or "Friend"
The faction itself you're looking at should appear as "Own".

EditorRUS changed Category from none/unspecified to Engine.
EditorRUS set First occurrence (version) to v0.19556.
EditorRUS edited Serverconfig (server.cfg). (Show Details)
EditorRUS edited Clientconfig (settings.cfg). (Show Details)
EditorRUS changed Reproducible from uncertain to Yes.
EditorRUS edited Steps to reproduce. (Show Details)
EditorRUS added a subscriber: EditorRUS.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptJan 31 2016, 5:12 AM
EditorRUS edited the task description. (Show Details)Jan 31 2016, 5:17 AM
EditorRUS set Issue Type to Bug.
EditorRUS set OS-Specific to No.
EditorRUS set Hardware-Specific to No.
EditorRUS set Video Card Vendor to uncertain.
EditorRUS set Affected Gamemode(s) to none/unspecified.
EditorRUS changed the title from "View relations not working right" to ""View Relations" does not display correct values".Jan 31 2016, 5:25 AM
lancake claimed this task.Jan 31 2016, 1:04 PM
lancake added a subscriber: lancake.

-Feedback-

Hm, I see. This is a small inconsistency then. It shows "Own" in red because your faction is an enemy to the one you're looking at, that's intended and seems logical to me.

The "Friend" part should in this case be "Own" in light blue.

Do you agree or do you had something else in mind?

lancake triaged this task as "Trivial" priority.Jan 31 2016, 1:05 PM
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake changed First occurrence (version) from v0.19556 to 0.19556.
lancake changed Affected Gamemode(s) from none/unspecified to Single and Multi.
lancake set Last tested (version) to 0.19556.
lancake moved this task from New / Unconfirmed to Feedback on the Workflow Issue Navigation board.

Yeah, that's right. I haven't found any other problem with this yet.

-Confirmed-

Putting in queue then.

The issue is a small inconsistency or mix-up:

  • Your faction appears as "Own" when looking at another faction's relations.
  • That faction appears as "Friend" when looking at its faction's relations.

Your own faction should just appear as any other faction when looking at someone else's faction relation. Which is "Enemy", "Neutral" or "Friend"
The faction itself you're looking at should appear as "Own".

lancake changed the title from ""View Relations" does not display correct values" to ""View Relations" does not display correct relationship values".Feb 1 2016, 1:39 PM
lancake changed the task status from "Open" to "In Queue (Game)".
lancake edited Steps to reproduce. (Show Details)
lancake edited Tester information (Internal use only). (Show Details)
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 4:05 PM
schema added a subscriber: schema.

-QA Testing-

Fix confirmed.

lancake changed Last tested (version) from 0.19556 to 0.19602 (Dev).Mar 10 2016, 6:07 PM
lancake closed this task as "Closed".
Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 10 2016, 6:07 PM

Add Comment