Starmade | using thrusters and mouse input while power outage causes fast spinning
Closed, FinishedPublic


If you run out of power and get the flashing red GUI (with sometimes outage recovery) you can still orientate yourself with the mouse.

However, when you are still using the keyboard to try and move around, you will not be able to orientate yourself.
Just run out of power and try to move and orientate at the same time, you'll notice what I mean.


Testing Results
Affected Gamemode(s)
Single and Multi
Last tested (version)
0.19602 (Dev)
Issue Type
First occurrence (version)
Video Card Vendor
Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
lancake created this task.Jun 9 2015, 9:09 AM
lancake changed Category from none/unspecified to Engine.
lancake changed Affected Gamemode(s) from none/unspecified to Single and Multi.
lancake set First occurrence (version) to 0.163.
lancake changed Reproducible from uncertain to Yes.
lancake set Last tested (version) to 0.19247 (Dev).
lancake edited a custom field.
lancake edited Serverconfig (server.cfg). (Show Details)
lancake edited Clientconfig (settings.cfg). (Show Details)
lancake added a subscriber: lancake.
lancake changed the task status from "Open" to "In Queue (Game)".Jun 10 2015, 9:27 AM
AndyP shifted this object from the S1 Public space to the S3 Starmade space.Aug 11 2015, 10:36 PM
AndyP changed the edit policy from "Starmade (Project)" to "All Users".
AndyP set Issue Type to Bug.
AndyP set OS-Specific to No.
AndyP set Hardware-Specific to No.
AndyP set Video Card Vendor to uncertain.
lancake claimed this task.Sep 21 2015, 10:48 AM
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 6:42 PM
schema added a subscriber: schema.

-QA Testing-

Fix confirmed.

lancake closed this task as "Closed".Mar 10 2016, 5:04 PM
lancake changed Last tested (version) from 0.19247 (Dev) to 0.19602 (Dev).
Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 10 2016, 5:04 PM

@lancake @schema

I request a re-open

0.198.485 Not fixed yet. It just happened to me.

Ship used = 1 core + 1 basic rail + 1 camera + 1 AI module + 1console board.
I destroyed all blocks but the core and reach ~51% structure HP.
That'd cause a power and thruster outage.
The result was an unbearable weird hi-speed spin impossible to stop without reboot while trying to move.

It was really nasty. Gif version is slower than the ingame spin but you'll get the idea from it. That hi-speed spin should be prevent anyhow cause that kind of thing can be dangerous for epileptics and very unpleasant for others.

This task was about you running out of power (which kills your thrust). Not about the SHP penalties.

@lancake Ok, so should I open a new one ? Because it's may not the same cause but it's the same result. SHP ==> power & trust outage ==> uncontrolable spin.

Add Comment