Starmade | Cannons with penetration depth have damage loss
Closed, FinishedPublic

Description

Test setup was a cannon system with 20 blocks, total damage = 200, damage instances: 115.2, 62.7, 22.2. Supposed damage versus advanced armor is 25 with armor HP, 50 without, but actual damage was 22 and 48.

This can't be explained by rounding errors, even if rounding down damage numbers before and after factoring in damage reduction.
115 * 0.125 + 62 * 0.125 + 22 * 0.125 = 14 + 7 + 2 = 23

A comparison test with 10 cannon blocks (100 damage, 1 damage instance) yields the correct numbers, 12(.5) and 25 damage.

Details

Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19602 (Dev)
Issue Type
Bug
Category
Control Block System: Weapons
First occurrence (version)
0.19538
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
NVIDIA
Steps to reproduce

Cannon test:

  • Place down 50 cannons in a single group: this is 500 damage total
  • Make a target ship and put advanced armor blocks on it, make sure to put its armor HP on 0 to disable the armor HP absorption.
  • You should deal 121 block HP damage, which is 484 EHP. This is 16 less than what it should be (not too bad)

Beam test:

  • Same as before but you need to buff a block's EHP in order to not kill it
  • The result is a lot more drastic since in my case about 50% of its damage didn't apply although that's probably because of T1024?
Tester information (Internal use only)

Happens for both beams and cannons but I'm unable to see a pattern in it.
If cannons or beams have more than penetration depth per group, it seems that some damage is lost if multiple instances have to be added up to kill a block.

It's a lot worse for beams than cannons, I did test this out for armor blocks which means beams add their damage up anyway. I've only killed 800 EHP out of the 1500 EHP it should be able to damage which is very odd (probably caused by T1024).

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
Malacodor changed Category from none/unspecified to Control Block System: Weapons.
Malacodor changed Video Card Vendor from uncertain to NVIDIA.
Malacodor edited Serverconfig (server.cfg). (Show Details)
Malacodor edited Clientconfig (settings.cfg). (Show Details)
Malacodor changed Affected Gamemode(s) from none/unspecified to Singleplayer.
Malacodor changed Reproducible from uncertain to Yes.
Malacodor set Last tested (version) to 0.19538.
Malacodor edited Steps to reproduce. (Show Details)
Malacodor added a subscriber: Malacodor.
lancake claimed this task.Jan 19 2016, 7:31 PM
lancake added a subscriber: lancake.

Hm yeah, tried it out on the simplest setup possible, 45 cannons, 10 damage each on basic hull with no armor HP. I've destroyed 390 HP of the 450 HP.

lancake triaged this task as "Normal" priority.Jan 19 2016, 7:32 PM
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake set Issue Type to Bug.
lancake set First occurrence (version) to 0.19538.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake changed Affected Gamemode(s) from Singleplayer to Single and Multi.
lancake changed Last tested (version) from 0.19538 to 0.19549.

Will need to check if the same goes for other weapons like beams or missiles.

-Confirmed-

Happens for both beams and cannons but I'm unable to see a pattern in it.
If cannons or beams have more than penetration depth per group, it seems that some damage is lost if multiple instances have to be added up to kill a block.

It's a lot worse for beams than cannons, I did test this out for armor blocks which means beams add their damage up anyway. I've only killed 800 EHP out of the 1500 EHP it should be able to damage which is very odd.

lancake changed the title from "Cannons with multiple damage instances do too little damage" to "Cannons and beams with penetration depth do too little damage".Feb 3 2016, 3:25 PM
lancake changed Last tested (version) from 0.19549 to 0.19556.
lancake edited Steps to reproduce. (Show Details)
lancake edited Tester information (Internal use only). (Show Details)
lancake changed the task status from "Open" to "In Queue (Game)".
lancake changed the title from "Cannons and beams with penetration depth do too little damage" to "Cannons and beams with penetration depth have damage loss".Feb 3 2016, 3:30 PM
lancake edited Steps to reproduce. (Show Details)Feb 3 2016, 3:45 PM
lancake edited Tester information (Internal use only). (Show Details)
This comment was removed by Malacodor.
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 9 2016, 4:46 PM
schema added a subscriber: schema.

in case of a beam issue remaining. it should be handled in a different issue

Does seem fixed for cannons, beams still show an issue but that's most likely because of T1024.

I'll take a look at this again later.

lancake changed Last tested (version) from 0.19556 to 0.19602 (Dev).Mar 10 2016, 6:02 PM
lancake changed the title from "Cannons and beams with penetration depth have damage loss" to "Cannons with penetration depth have damage loss".Mar 20 2016, 1:21 AM
lancake closed this task as "Closed".

-QA Testing-

Can't see this specific issue with cannons anymore, can't test it out with beams when T1024 is around but as schema said, will require a new task if needed.

Renaming this task and closing it.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 20 2016, 1:23 AM

Add Comment