Starmade | Personal Cargo drops at astronaut position on death w/ setting on
Closed, FinishedPublic

Description

Seems that if you die while your Personal Cargo is set, on a server with "PLAYER_DEATH_BLOCK_PUNISHMENT = true", you drop the cargo container's storage into space at your astronaut's position, rather than leaving it in its storage module.

However, the storage module will say that it still has all of its contents in it afterwards - this is incorrect, and placing blocks into the storage unit will correct the number of modules of that type displayed.

Details

Commits
Restricted Diffusion Commit
Testing Results
Affected Gamemode(s)
Single and Multi
Reproducible
Yes
Last tested (version)
0.19618 (Dev)
Issue Type
Bug
Category
Control Block System: Functional
First occurrence (version)
0.19538
Hardware/Software/System
OS-Specific
No
Hardware-Specific
No
Video Card Vendor
uncertain
Steps to reproduce

Set server config to drop cargo on death.
Set container as Personal Cargo, fill container with junk.
Go get killed in the general vicinity of the container while your inventory is set to use Cargo.

Tester's Steps:
Make a cargo container and set it as your personal cargo
Put stuff into it
Cause player death.
You will see that you have dropped your items from your personal cargo, though you may need to attempt to move around items to get it to update.

Tester information (Internal use only)

Partially fixed:

Your normal inventory doesn't get dropped now, the message still appears though.

Serverconfig (server.cfg)
<replace this line with the file content>
Clientconfig (settings.cfg)
<replace this line with the file content>
Azereiah created this task.Jan 10 2016, 6:10 PM
Azereiah changed Category from none/unspecified to Control Block System: Functional.
Azereiah edited Serverconfig (server.cfg). (Show Details)
Azereiah edited Clientconfig (settings.cfg). (Show Details)
Azereiah changed Affected Gamemode(s) from none/unspecified to Single and Multi.
Azereiah changed Reproducible from uncertain to Yes.
Azereiah set Last tested (version) to 0.19538.
Azereiah edited Steps to reproduce. (Show Details)
Azereiah added a subscriber: Azereiah.
Restricted Application added a project: Workflow Issue Navigation. · View Herald TranscriptJan 10 2016, 6:10 PM

-Validated-

Hm, not intended for sure, good catch ^^

lancake claimed this task.Jan 10 2016, 9:21 PM
lancake triaged this task as "Release Blocker" priority.
lancake shifted this object from the S1 Public space to the S3 Starmade space.
lancake changed the visibility from "Custom Policy" to "Public (No Login Required)".
lancake changed the edit policy from "Task Author" to "Starmade (Project)".
lancake set Issue Type to Bug.
lancake set First occurrence (version) to 0.19538.
lancake set OS-Specific to No.
lancake set Hardware-Specific to No.
lancake set Video Card Vendor to uncertain.
Restricted Application added a subscriber: AndyP. · View Herald TranscriptJan 10 2016, 9:22 PM
lancake removed lancake as the assignee of this task.Jan 13 2016, 10:44 PM
Zackey_TNT added a subscriber: Zackey_TNT.

Claiming.

Zackey_TNT changed the task status from "Open" to "In Queue (Game)".Jan 14 2016, 12:31 AM

Issue -Confirmed-

On death, cargo items do drop from inventory and fail to update.

Steps to reproduce:

Make a cargo container and set it as your personal cargo
Put stuff into it
Cause player death.
You will see that you have dropped your items from your personal cargo, though you may need to attempt to move around items to get it to update.

Zackey_TNT changed Last tested (version) from 0.19538 to V0.19544 (Dev).Jan 14 2016, 12:32 AM
Zackey_TNT edited Steps to reproduce. (Show Details)
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 19 2016, 8:40 PM
schema added a subscriber: schema.
thatothermitch added a commit: Restricted Diffusion Commit.Mar 19 2016, 9:21 PM
lancake changed the task status from "Resolved" to "In Queue (Game)".Mar 19 2016, 10:48 PM

-QA Testing-

Partially fixed

You don't drop your cargo inventory if it's open so the original issue is fixed but 2 more issues were introduced:

  • if you have personal cargo ENABLED, you don't drop your astronaut's inventory (the one you would have without personal cargo enabled)
  • if you have personal cargo DISABLED, you spawn a copy of your astronaut's inventory, but your astronaut's inventory doesn't get wiped so you get item duplication.
lancake edited Tester information (Internal use only). (Show Details)Mar 19 2016, 10:48 PM
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 19 2016, 10:58 PM
lancake changed the task status from "Resolved" to "In Queue (Game)".Mar 20 2016, 12:54 AM

-QA Testing-

Partially fixed:

Your normal inventory doesn't get dropped now, the message still appears though.

lancake edited Tester information (Internal use only). (Show Details)Mar 20 2016, 12:55 AM
lancake changed Last tested (version) from V0.19544 (Dev) to 0.19616 (Dev).
schema changed the task status from "In Queue (Game)" to "Resolved".Mar 20 2016, 1:41 AM
lancake closed this task as "Closed".

-QA Testing-

Fix confirmed.

Restricted Application removed a project: Workflow Quality Assurance. · View Herald TranscriptMar 20 2016, 2:54 AM
Restricted Application removed a subscriber: AndyP. · View Herald Transcript
lancake changed Last tested (version) from 0.19616 (Dev) to 0.19618 (Dev).Mar 20 2016, 2:55 AM

Add Comment